Solved GroupManager Bug?

Discussion in 'Spigot Plugin Help' started by ColbyPlayzYT, May 27, 2016.

  1. Can someone tell me what this means. I have my permissions set up and now this keeps showing up not letting me use any permissions:

    ERROR:

    2016-05-26 20-39
    =============================== GM ERROR LOG ===============================
    = ERROR REPORT START - 2.0.1-b332 =

    java.lang.NullPointerException
    at org.anjocaido.groupmanager.utils.Tasks.copy(Tasks.java:44)
    at org.anjocaido.groupmanager.dataholder.worlds.WorldsHolder.setupWorldFolder(WorldsHolder.java:603)
    at org.anjocaido.groupmanager.dataholder.worlds.WorldsHolder.mirrorSetUp(WorldsHolder.java:176)
    at org.anjocaido.groupmanager.dataholder.worlds.WorldsHolder.initialLoad(WorldsHolder.java:97)
    at org.anjocaido.groupmanager.dataholder.worlds.WorldsHolder.resetWorldsHolder(WorldsHolder.java:86)
    at org.anjocaido.groupmanager.dataholder.worlds.WorldsHolder.<init>(WorldsHolder.java:53)
    at org.anjocaido.groupmanager.GroupManager.onEnable(GroupManager.java:176)
    at org.anjocaido.groupmanager.GroupManager.onEnable(GroupManager.java:99)
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:292)
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:340)
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405)
    at org.bukkit.craftbukkit.v1_9_R2.CraftServer.loadPlugin(CraftServer.java:361)
    at org.bukkit.craftbukkit.v1_9_R2.CraftServer.enablePlugins(CraftServer.java:321)
    at net.minecraft.server.v1_9_R2.MinecraftServer.t(MinecraftServer.java:416)
    at net.minecraft.server.v1_9_R2.MinecraftServer.l(MinecraftServer.java:381)
    at net.minecraft.server.v1_9_R2.MinecraftServer.a(MinecraftServer.java:336)
    at net.minecraft.server.v1_9_R2.DedicatedServer.init(DedicatedServer.java:268)
    at net.minecraft.server.v1_9_R2.MinecraftServer.run(MinecraftServer.java:532)
    at java.lang.Thread.run(Unknown Source)

    ============================================================================
     
  2. MiniDigger

    Supporter

    groupmanager is not really supported anymore. you should look into alternatives (hint: pex)
    but anyways, your versions seems to be outdated too (looks likes its years old lol)
    current one is 2.13.1 you got 2.0.1
    https://www.spigotmc.org/resources/groupmanager.23/
     
    • Winner Winner x 1
  3. Thank you so much! This fixed it and now my perms work!
     
  4. MiniDigger

    Supporter

    where did you event get that version? ^^
     
  5. I think i was watching a tutorial and the download link was old. I dont even remember what vid.
     
    • Funny Funny x 2