1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Groupmanager & Essentials Configuration

Discussion in 'Bugs & Feature Requests' started by Software_Update, Jan 14, 2015.

  1. I don't know if this is the proper section to post this but, I hope you guys can help me. I have a very minor bug, my players nor donors can issues the kits that they are given. What I mean by that is that they are denied permission to issue the command /kit which to me poses a big problem, no functioning kits system means no players. I've gone through my Groupmanager Permissions at least a good eight times and check letter by letter and space by space for a flaw, but nothing. I also went through my kits configuration and essetials configuration to check for anything there, but once again nothing turned up. The reason why I come here is searching for help, I hear that you guys on the Spigot forums are the individuals with the most experience in Minecraft server administrating and I'm hoping one of you may help me with this issue. I will be posting both my Group Manager and Essentials configurations below if you're interested, I will be giving a small donor rank to the person who fixes this (for motivation).

    Groupmanager Configuration: http://pastebin.com/jSFyXzRe
    Essentials Configuration: http://pastebin.com/630Pv3s3


  2. Isn't this supposed to be kit(s)? essentails.kit, then, essentials.kits.givethemthekit
    Code (Text):
     - essentials.kit.Elite
  3. Here's Pex, Maybe GM is different but I doubt it.
    Code (Text):
        - essentials.kit
        - essentials.kits.tools
        - essentials.kits.dtools
        - essentials.kits.notch
        - essentials.kits.color
  4. The information you have supplies me with is insufficient, I still have this issue.
  5. You typed the permission for kits wrong.
    The permission should read like this:

    - essentials.kits.Premium

    but yours says essentials.kit.Premium. just add the "s" and you should be good to go.
  6. Still doesn't work. I've tried this before and had the same issue
  7. You also need the essentials.kit too or just give up on running a server...its not that difficult.
  8. You chill, saying I didn't supply you with sufficient information...this is not a pay service...
  9. Still giving away a rank for the guy who fixes this! If anyone is interested.
  10. I don't want a rank but your .yml is not formatted properly...Remember 99.9% of the people on here "own" a server.
    Code (Text):
        delay: 86400
         - 306 1 name:&fPlayer
          - 307 1 name:&fPlayer
          - 308 1 name:&fPlayer
          - 309 1 name:&fPlayer
          - 272 1 Sharpness:1
          - 274 1
          - 275 1
          - 291 1
          - 373:8258 1
          - 373:8259 1
          - 373:8269 1
          - 373:8262 1
          - 338 32
          - 296 32
          - 392 21
          - 364 16
        delay: 345600
         - 298 1 protection:4 unbreaking:3 name:&9Premium
          - 299 1 protection:4 unbreaking:3 name:&9Premium
          - 300 1 protection:4 unbreaking:3 name:&9Premium
          - 301 1 protection:4 unbreaking:3 name:&9Premium
    All these lines that have "-" must line up perfectly, I am surprised it doesn't throw a error. There may be other errors but this one jumped out at me.
  11. Ok, thank you. I will let you know at a further time if this worked.
  12. This is still an ongoing issue on my server. The problem is that the configuration for the kits is perfectly made, I mean I have access to them because I'm an Operator. Other players however do not. You can go through my GroupManager configuration and have a look and see if they are coded properly, because I have no idea if they are.
  13. As soon as I get home, I will. Thanks mate.
    • Like Like x 1
  14. Still does not function, gave me an error message too, Fixed it then re-tried didn't work after that.
  15. 1 whole week on GM and essentials? I gotta say one thing, you are not in a hurry! Good luck!
  16. Please write the error message
  17. I noticed another thing in your config...your delay is set for 86,400 seconds...that's a long time to wait for a kit don't you think? (So you want it to 1 kit per day even if they have the permission?)
  18. Investigated error message, was not linked to configuration of the plugin.