Spigot GroupManager v2.8

The original permission plugin maintained and updated by ElgarL

  1. symvizan submitted a new resource:

    GroupManager - Download provided for a version of GroupManager working on the latest versions.

    Read more about this resource...
     
  2. Why are you even uploading this while it isnt yours. When people need it they google it.
     
    • Agree Agree x 2
  3. There is no working one out there.
     
  4. Who ever is doing this, you are the best. <3
     
    • Like Like x 1
    • Agree Agree x 1
    • Friendly Friendly x 1
  5. idgaf about no support, you said (or someone, sorry im just really annoyed) that this should work w/ essentialsX. Yet the permissions for setting spawn with essentialsx spawn doesn't work. Even with the '*' node. Please fix this, its really pissing me off and bugging the hell out of my players and friends.
     
    • Funny Funny x 1
    • Informative Informative x 1
  6. Have you used the right version? It works for me.
     
  7. I completely understand there is no support given here. However, does anyone know where I could find some help? I'm new to owning a server and completely new to using yml's and well everything else associated. I've got everything else good to go, but my group yml settings continue to come back wrong. Please understand I've already spent hours in the wiki, and because I work so much and have kids I cant pour over this stuff until I get it right.

    On that note... anyone know a good resource for devs or admins who have extensive knowledge in these regards? I don't want someone joining my server and telling me they know everything, I'd rather a more extensive vetting process.

    Error log from console is below. There was no error log generated for this in the groupmanager folder.

    [Server thread/WARN]: GroupManager - SEVERE - There are errors in your config.yml. Using default settings

    Group settings under world folder:
    https://docs.google.com/document/d/1lQGhQ7rh0Rjk9BZ1MOCyWpLCkxc-AOYewW7mt8NeLzs/edit?usp=sharing

    Master group settings YML (not world) this didn't throw any errors I believe, but well I'm obviously wrong about something.

    https://docs.google.com/document/d/1D2Yw3HWUKBBKWK9Ir9XGegg4IgUxs86ecvJUsoJA4A4/edit?usp=sharing

    If anyone has any ideas please let me know!

    Regards,

    ~Roy
     
  8. Salut, je cherche un plugin de permission, celui ci est très bien mais il manque le support MYSQL ! pouvez vous l'ajouter ? merci :D
     
  9. I'm not sure if this is the right place to post my question about groupmanager (sorry if not).

    So I am running multiverse with world X and Y (for example) and the groups that I created with groupmanager on world Y are inherited from world X.

    So say there is a promotion that is made on world Y (change in group), would it update world X too? Or would world X simply revert world Y to before the promotion was made?
     
    • Like Like x 1
  10. Just let GroupManager die already, its a lost cause, and it barely even has as many features as Pex or Luckperms.
     
    • Like Like x 1
  11. Deep breath...

    Thank .. <pause> .. YOU .. <fast talk> .. so much.
     
    • Like Like x 1
    • Funny Funny x 1
  12. Maybe it's time to implement them :)
     
    • Agree Agree x 2
  13. Even though I have Ultra Permissions, the only thing that I like about Group Manager is adding multiple permissions at once in one command. Perhaps, you could try to add GUI for utilities (such as SQL and bungeecord support, managing permissions & groups) for the features.

    Thanks for updating the plugin to 1.13.x.
     
    • Friendly Friendly x 1
  14. On our roadmap is sync between Bungee servers, RegEx permissions and maybe SQL support. However nothing is guaranteed, it's up to our dev's passion.
     
  15. [22:09:07] [Server thread/INFO]: [WorldEdit] Enabling WorldEdit v6.1.9;caf0ad9
    [22:09:08] [Server thread/INFO]: WEPIF: GroupManager detected! Using GroupManager for permissions.
    [22:09:08] [Server thread/ERROR]: Error occurred while enabling WorldEdit v6.1.9;caf0ad9 (Is it up to date?)
    java.lang.IllegalArgumentException: Channel must contain : separator (attempted to use WECUI)
    at org.bukkit.plugin.messaging.StandardMessenger.validateAndCorrectChannel(StandardMessenger.java:474) ~[spigot.jar:git-Spigot-947a8e7-17ff1e0]
    at org.bukkit.plugin.messaging.StandardMessenger.registerIncomingPluginChannel(StandardMessenger.java:209) ~[spigot.jar:git-Spigot-947a8e7-17ff1e0]
    at com.sk89q.worldedit.bukkit.WorldEditPlugin.onEnable(WorldEditPlugin.java:110) ~[?:?]
    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:254) ~[spigot.jar:git-Spigot-947a8e7-17ff1e0]
    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:339) [spigot.jar:git-Spigot-947a8e7-17ff1e0]
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:403) [spigot.jar:git-Spigot-947a8e7-17ff1e0]
    at org.bukkit.craftbukkit.v1_13_R2.CraftServer.enablePlugin(CraftServer.java:434) [spigot.jar:git-Spigot-947a8e7-17ff1e0]
    at org.bukkit.craftbukkit.v1_13_R2.CraftServer.enablePlugins(CraftServer.java:348) [spigot.jar:git-Spigot-947a8e7-17ff1e0]
    at net.minecraft.server.v1_13_R2.MinecraftServer.l(MinecraftServer.java:584) [spigot.jar:git-Spigot-947a8e7-17ff1e0]
    at net.minecraft.server.v1_13_R2.MinecraftServer.a(MinecraftServer.java:546) [spigot.jar:git-Spigot-947a8e7-17ff1e0]
    at net.minecraft.server.v1_13_R2.MinecraftServer.a(MinecraftServer.java:424) [spigot.jar:git-Spigot-947a8e7-17ff1e0]
    at net.minecraft.server.v1_13_R2.DedicatedServer.init(DedicatedServer.java:294) [spigot.jar:git-Spigot-947a8e7-17ff1e0]
    at net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.java:702) [spigot.jar:git-Spigot-947a8e7-17ff1e0]
    at java.lang.Thread.run(Thread.java:748) [?:1.8.0_191]
     
  16. Exception is caused by WorldEdit.