Premium GUIPlus - Simply create clickable GUI's (Ingame GUI Builder) [1.7 - 1.18] [Paid]

Discussion in 'Resource Discussion' started by kinglol12345, Apr 8, 2017.

  1. That's the Default Message I guess. And the Command isn't recognized, because you've added / before the Command.
    Like the Messages tells you add Commands without Slash ^^
  2. Oh, I'm sorry about that photo I showed, I was testing different ways to see if I was doing it wrong, I know you're not supposed to do the slash, even if I don't do the slash and do something like <op>heal it still doesn't work. I've tried to delete resent plugins I've added to see if anything is interfering and nothing seems to work.

  3. But you have a Heal Plugin installed? xD It could be that you heal Plugin haven't registered the Command, because it only works with registered Commands. Do you have Discord?
  4. Yes, I do have Discord.

    Username: (For some reason my username won't work because it keeps getting deleted so just join the server I created just now) #4416

    Or you can join this server, it's just me in it:

    And also, I do have essentials installed, and when I do /heal it works fine, but it's not wanting to work when I click the item in the GUI.
  5. Restarting the server after editing the GUI in some plugins causes some GUI to initialize...
    After the update, all the symptoms disappeared.
    But it's still the same in the old GUI.
    So I started writing a new GUI again :)
    • Like Like x 1
  6. Is it possible to create a Gui for Creative Plots so that when a player claims a plot the GUI automatically opens up? This is my no1 need right now.
  7. No thats Not possible. But can be easy Made with a Simple Plugin.
  8. Soo, I got an issue, when I put something on a gui that I made, it just disappears when I open it again. I'm using the 2.03 version
  9. Can you send me a Video pls
  10. I just purchased this plugin and started working with some basic menu tests, so far it is working good.

    I do have an issue when I try to add permissions to the menu or menu items.

    I enter this into the chat when prompted:

    but it is saved as: gui menu mmtools member

    So I tried entering is as ''

    In Game Editor shows as: 'gui menu mmtools member'
    config files shows:
    permission: '''gui menu mmtools member'''

    Not sure if I am missing something or not.


    EDIT: downloading and upgrading to the latest version 2.03 has resolved the issue.
    #371 IggyMonBullder, May 1, 2020
    Last edited: May 1, 2020
  11. Any plans to add tab complete to the aliases that open the GUIs?
  12. Yes thanks, but it is an essential, that you can make a menu with several pages, and it looks bad at the moment, if you do that. Good plugin otherwise!
  13. Yes it's on my TO-DO :)

    Absolutely, but it works and that's the most Important Part at the Moment, because I want to add more Features first :)
    • Like Like x 1
  14. I recently purchase this plugin and it is awesome, but I have a few questions about the GUI..

    Are you supposed to be able to move item 1 to item 3 in the GUI edit screen?

    If so,

    Is it normal that this procedure erases all of the actions on both items?
    - the config only saves the item#, type, display-name, and lores
    - the rest is removed including actions, price, permissions, commands, etc.

    Is it better to just manually swap the location in the config file directly?​


    Is there anyway to change the type (ITEM_ID) in the GUI, or is that a direct config file edit too?

    The rest is working flawlessly thus far.

  15. Changing the Item Id I already thought about.
    You're not able to move Items in the Edit Screen or the Actions will be lost, and it's also not planned to change it in the Future.
    Begin with designing the GUI and the the Logic :)
  16. Okay, not a problem. I just wanted to make sure I wasn't doing something wrong. :unsure:
    Just part of the testing of the Plugin, (cart before the horse) a simple fix in the config if really needed.

    Thanks for the confirmation.
  17. Hi.

    I can't add new items. The item block just does not work. I do left-click and I leave there the items and then when I do ESC for taking another item or just for being that gui saved, it does not get saved. When I left-clic, there is everything empty again.

    Plugin's version: 2.04
    Server's version: This server is running CraftBukkit version git-Spigot-2040c4c-893ad93 (MC: 1.15.2) (Implementing API version 1.15.2-R0.1-SNAPSHOT) You are 5 version(s) behind