Bukkit GUIShop 7.1.5

This plugin is the ultimate solution to all the signs, the chests, the glitches.

  1. I've noticed a lot of people talk about the following error:
    [Server] ERROR Could not pass event InventoryClickEvent to GUIShop
    I've noticed this only happens when the plugin can't find the item you've added to the store. This exception should be handled by the plugin and produce a more direct statement in the console.
     
  2. It happens in the main menu and it didn't even get edited from the normal config the Dev just don't know how to program his plugin. I put up with it for about 6 months and after the 7.0b I got fed up and stopped using it completely after it didn't even start up.
     
  3. I'm using 1.13.2 and I was able to get the plugin to fully function with only configuration. I also had it break immediately after setting it up, but if you read through the rest of the error, it always listed a specific item that broke the menus. After fixing the item name and restarting the server multiple times, I was able to have a fully functioning GUI store. If it didn't list an item, perhaps another plugin was breaking it.
     
  4. With the latest update? If so the dev discontinued support for 1.8-1.12 and didn't say crap. Mind you the dev has yet to update the plugin after asking them to fix the bug with the latest update and showing the log of the error.
     
  5. Yeah, if you were having problems, I'd take another look at your logs. I just broke mine to demonstrate, this is the error caused. Note the line
    Caused by: java.lang.IllegalArgumentException: No enum constant org.bukkit.Material.EGGytyt.
    The items you add have to exactly match an item within Minecraft. I added ytyt to the end of EGG, and even though the menu shows up, it instantly breaks when I try to open the submenu containing the invalid item.



    [13:10:09 ERROR]: Could not pass event InventoryClickEvent to GUIShop v7.0B
    org.bukkit.event.EventException: null
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:309) ~[spigot.jar:git-Spigot-e5e5c7c-6430d9c]
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62) ~[spigot.jar:git-Spigot-e5e5c7c-6430d9c]
    at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:501) ~[spigot.jar:git-Spigot-e5e5c7c-6430d9c]
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:486) ~[spigot.jar:git-Spigot-e5e5c7c-6430d9c]
    at net.minecraft.server.v1_13_R2.PlayerConnection.a(PlayerConnection.java:2123) ~[spigot.jar:git-Spigot-e5e5c7c-6430d9c]
    at net.minecraft.server.v1_13_R2.PacketPlayInWindowClick.a(SourceFile:33) ~[spigot.jar:git-Spigot-e5e5c7c-6430d9c]
    at net.minecraft.server.v1_13_R2.PacketPlayInWindowClick.a(SourceFile:10) ~[spigot.jar:git-Spigot-e5e5c7c-6430d9c]
    at net.minecraft.server.v1_13_R2.PlayerConnectionUtils.lambda$0(PlayerConnectionUtils.java:9) ~[spigot.jar:git-Spigot-e5e5c7c-6430d9c]
    at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) [?:1.8.0_201]
    at java.util.concurrent.FutureTask.run(Unknown Source) [?:1.8.0_201]
    at net.minecraft.server.v1_13_R2.SystemUtils.a(SourceFile:199) [spigot.jar:git-Spigot-e5e5c7c-6430d9c]
    at net.minecraft.server.v1_13_R2.MinecraftServer.b(MinecraftServer.java:896) [spigot.jar:git-Spigot-e5e5c7c-6430d9c]
    at net.minecraft.server.v1_13_R2.DedicatedServer.b(DedicatedServer.java:417) [spigot.jar:git-Spigot-e5e5c7c-6430d9c]
    at net.minecraft.server.v1_13_R2.MinecraftServer.a(MinecraftServer.java:831) [spigot.jar:git-Spigot-e5e5c7c-6430d9c]
    at net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.java:729) [spigot.jar:git-Spigot-e5e5c7c-6430d9c]
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_201]
    Caused by: java.lang.IllegalArgumentException: No enum constant org.bukkit.Material.EGGytyt
    at java.lang.Enum.valueOf(Unknown Source) ~[?:1.8.0_201]
    at org.bukkit.Material.valueOf(Material.java:1) ~[spigot.jar:git-Spigot-e5e5c7c-6430d9c]
    at com.pablo67340.guishop.listenable.Shop.loadShop(Shop.java:300) ~[?:?]
    at com.pablo67340.guishop.listenable.Menu.onShopClick(Menu.java:205) ~[?:?]
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_201]
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_201]
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_201]
    at java.lang.reflect.Method.invoke(Unknown Source) ~[?:1.8.0_201]
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:305) ~[spigot.jar:git-Spigot-e5e5c7c-6430d9c]
    ... 15 more
     
  6. I can't look at the darn log cause it doesn't START UP THE PLUGIN
     
  7. Is this plugin still being updated?
     
  8. Iam trying to use this Plugin on an Modded 1.7.10 Server.
    My problem is that the commands only work 1 time, after it the Console gets out an error.

    Ive tested the version 7.0.0b and some versions below.

    Wich version supports 1.7.10 and is supporting Modded Servers?

    //Edit

    Ive found an workin Version, but now ive an question:
    Is Mysql-Support for 1.7.10 comeing soon?
     
    #889 LordKimahri, Mar 9, 2019
    Last edited: Apr 3, 2019
  9. Players can click and hold on the menu items when they do /shop and take things.
     
  10. Installed 7.1.1 and got this error as I tried to buy permissions/commands:
    [18:01:47 ERROR]: Could not pass event PlayerCommandPreprocessEvent to GUIShop v
    7.1.1
    java.lang.IllegalArgumentException: null
    at java.util.Date.parse(Unknown Source) ~[?:1.8.0_202]
    at java.util.Date.<init>(Unknown Source) ~[?:1.8.0_202]
    at com.pablo67340.guishop.definition.Expires.setExpiration(Expires.java:
    31) ~[?:?]
    at com.pablo67340.guishop.definition.Expires.<init>(Expires.java:13) ~[?
    :?]
    at com.pablo67340.guishop.definition.ItemCommand.<init>(ItemCommand.java
    :42) ~[?:?]
    at com.pablo67340.guishop.main.Main.loadCommands(Main.java:216) ~[?:?]
    at com.pablo67340.guishop.listenable.PlayerListener.onCommand(PlayerList
    ener.java:48) ~[?:?]
    at com.destroystokyo.paper.event.executor.asm.generated.GeneratedEventEx
    ecutor39.execute(Unknown Source) ~[?:?]
    at org.bukkit.plugin.EventExecutor.lambda$create$1(EventExecutor.java:69
    ) ~[patched_1.13.2.jar:git-Paper-597]
    at co.aikar.timings.TimedEventExecutor.execute(TimedEventExecutor.java:8
    0) ~[patched_1.13.2.jar:git-Paper-597]
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav
    a:66) ~[patched_1.13.2.jar:git-Paper-597]
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j
    ava:520) ~[patched_1.13.2.jar:git-Paper-597]
    at net.minecraft.server.v1_13_R2.PlayerConnection.handleCommand(PlayerCo
    nnection.java:1774) ~[patched_1.13.2.jar:git-Paper-597]
    at net.minecraft.server.v1_13_R2.PlayerConnection.a(PlayerConnection.jav
    a:1590) ~[patched_1.13.2.jar:git-Paper-597]
    at net.minecraft.server.v1_13_R2.PacketPlayInChat.a(PacketPlayInChat.jav
    a:45) ~[patched_1.13.2.jar:git-Paper-597]
    at net.minecraft.server.v1_13_R2.PacketPlayInChat.a(PacketPlayInChat.jav
    a:5) ~[patched_1.13.2.jar:git-Paper-597]
    at net.minecraft.server.v1_13_R2.PlayerConnectionUtils.lambda$ensureMain
    Thread$0(PlayerConnectionUtils.java:15) ~[patched_1.13.2.jar:git-Paper-597]
    at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) ~
    [?:1.8.0_202]
    at java.util.concurrent.FutureTask.run(Unknown Source) ~[?:1.8.0_202]
    at net.minecraft.server.v1_13_R2.SystemUtils.a(SystemUtils.java:108) ~[p
    atched_1.13.2.jar:git-Paper-597]
    at net.minecraft.server.v1_13_R2.MinecraftServer.b(MinecraftServer.java:
    1017) ~[patched_1.13.2.jar:git-Paper-597]
    at net.minecraft.server.v1_13_R2.DedicatedServer.b(DedicatedServer.java:
    439) ~[patched_1.13.2.jar:git-Paper-597]
    at net.minecraft.server.v1_13_R2.MinecraftServer.a(MinecraftServer.java:
    939) ~[patched_1.13.2.jar:git-Paper-597]
    at net.minecraft.server.v1_13_R2.MinecraftServer.run(MinecraftServer.jav
    a:836) ~[patched_1.13.2.jar:git-Paper-597]
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_202]
     
  11. '4':
    - id: SPAWNER
    - mobType: [TURTLE]
    - slot: 3
    - name: Turtle Spawner
    - buy-price: 75000.0
    - sell-price: 0.0
    - enchantments: ''
    - type: ITEM
    WDYM TURTLE
     
  12. Everything works except the silkspawners, i have guishop and silkspawners 1.13 installed the one you say to install. spawners are not buyable or sellable for some odd reason.
     
  13. pablo67340 updated GUIShop with a new update entry:

    Spawner Fixes

    Read the rest of this update entry...
     
  14. Is it possible to retrieve statistics for shop usage? I run a server that sells many, many items, and balancing the prices is a lot easier if you can see what players are selling the most of. Thanks.
     
  15. I got the problem that I can buy items when I dont even have the money for it. I get -... money. I would really appreciate it if someone could help me out.
     

    Attached Files: