Spigot HackedCore | HackedServer library 2.71.4

Loads different libraries used by HackedServer (but too heavy to be directly integrated)

  1. Her3sy submitted a new resource:

    HackedCore [HackedServer libraries] - Loads different libraries used by HackedServer (but too heavy to be directly integrated)

    Read more about this resource...
     
    • Agree Agree x 1
  2. What are your thoughts
     
  3. 3.3 megabytes ?

    what's in this :eek:
     
  4. Entire libraries not shrinked haha, so basically:
    - last version of byte-buddy
    - asm (contained in byte-buddy)
    - apache commons

    But I only use a small part of the libraries (and only it is loaded)
     
  5. latest version 2.59.1 reports 2.59.0 as it's version. minor bug, might also need update for related errors i'm posting on HS discussion in a moment
     
  6. Alright thanks.
     
  7. Is this compatible with 1.16.1 ?
     
  8. yes
     
  9. log files remain zero bytes, but in console even when testing with hack clients, and what not it shows it detects them, it makes a log file but they remain empty.

    java11, 64bit, macOS Catalina, paper 1.16.3
     

    Attached Files:

  10. Clients logging in with minechat wont show [hardlogging]
    the files are still zero bytes.
     
  11. Thanks for the report @mrfloris, I'll look into that.
     
  12. > [18:40:20] [Netty Epoll Server IO #2/ERROR]: [ClientDetector] PacketEvents found an exception while loading the WrappedPacketLoginOutCustomPayload packet wrapper. Please report this bug! Tell us about your server version, spigot and code(of you using the wrapper)
    java.lang.IllegalStateException: PacketEvents is unable to resolve the PacketPlayOutCustomPayload constructor

    Plugin for ban AdvancedBan