Having an issue with BungeeCord

Discussion in 'BungeeCord Discussion' started by Browning98, Oct 3, 2013.

  1. Im having a tad bit of trouble with BungeeCord on my Mac
    Im getting an error
    I have Java 7 and just having an issue with it not finding a BungeeCord.jar
    Code (Text):
    Last login: Wed Oct  2 19:52:32 on ttys000
    Matts-MacBook-Pro:~ matthew$ /Users/matthew/Desktop/BungeeCord.jar/run.command ; exit;
    Unable to access jarfile BungeeCord.jar
    logout
     
    [Process completed]
    If it helps here is my config file

    Code (Text):
    groups:
      md_5:
      - admin
    disabled_commands:
    - find
    player_limit: -1
    stats: 0d90b760-f4b9-4cf2-8e74-82da46a889df
    permissions:
      default:
      - bungeecord.command.server
      - bungeecord.command.list
      admin:
      - bungeecord.command.alert
      - bungeecord.command.end
      - bungeecord.command.ip
      - bungeecord.command.reload
    listeners:
    - max_players: 1
      fallback_server: lobby
      host: 0.0.0.0:25577
      bind_local_address: true
      ping_passthrough: false
      tab_list: GLOBAL_PING
      default_server: lobby
      forced_hosts:
        pvp.md-5.net: pvp
      tab_size: 60
      force_default_server: false
      motd: '&1Another Bungee server'
      query_enabled: false
      query_port: 25577
    timeout: 30000
    connection_throttle: 4000
    servers:
      lobby:
        address: localhost:25565
        restricted: false
        motd: '&1Just another BungeeCord - Forced Host'
    online_mode: true
     
     
  2. Dead-i

    Wiki Team

    What is the contents of run.command?
     
  3. This is what I have in the run.command file

    Code (Text):
    java -Xss192k -Xms256m -Xmx1G -jar BungeeCord.jar
     
  4. Dead-i

    Wiki Team

    Change it to something like:
    Code (Text):
    #!/bin/sh
    BINDIR=$(dirname "$(readlink -fn "$0")")
    cd "$BINDIR"
    java -jar BungeeCord.jar
    This will ensure it searches for BungeeCord.jar in the right directory.
    Also, no need for any Xms/Xmx stuff with BungeeCord - it can decide on its own.
     
  5. Still get the same error. Some odd reason it’s acting like it is not even there.
     
  6. Outlaw11A

    Supporter

    I would highly suggest not running it on your Mac.
     
  7. Dead-i

    Wiki Team

    Is your BungeeCord.jar located in the same folder as run.command? Is it actually named exactly "BungeeCord.jar"?
     
  8. Yes that was the first thing I check to make sure that the BungeeCord.jar was named correctly. Im going to give up on the mac server and try it on Linux.