1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Crash Having some strange crashes.

Discussion in 'Bugs & Feature Requests' started by MarcoSlater, Aug 21, 2013.

  1. Hello, I am currently hosting about 10 server's on a single machine, bound together by BungeeCord they carry about 200 people daily, since we switched to a new dedicated server (more powerful) I am starting to see some strange behavior, could someone help me with the following error logs?

    http://pastebin.com/i2sktbid

    http://pastebin.com/VFuH0MmT

    Thanks! :D

    Regards,
    Halothe23
     
    • Like Like x 1
  2. Dmck2b

    Services Staff

    First one was Multicrap.
    21.08 18:25:22 [Multicraft] Error writing to server: [Errno 32] Broken pipe
    21.08 18:25:22 [Multicraft] Error writing to server: [Errno 32] Broken pipe

    Second one was a metrics attempt timing out. Try disabling the metrics for Shortify.
     
    • Informative Informative x 1
  3. I believe the Multicraft gave out that error because the server crahsed beforehand? Or was it actually Multicraft?

    I'm opting out of the metrics on all of the server's.
     
  4. Dmck2b

    Services Staff

    I've seen it several times, never looked into it as I don't really care about a wrapper's issues. As far a sI could tell it was the one causing the crashes, though.

    It looks like redstone had some issues updating it's physics then causing a stack overflow. Not sure what could cause that.

    And again, multicrap cut off a lot of the crash.

    21.08 19:08:00 [Multicraft] Skipped 1764 lines due to rate limit (300/s)
     
    • Agree Agree x 1
  5. Raised the limit to 3000 lines a second, good enough to catch all the crashes? or should I go for 30k?
     
  6. I notice, some server's seem to lag out, with no real reason, although stats of the server its running on report no difference, is there a limit to how many server's you can run on a single machine? Currently running 9 and have about 200 people online spread across them (BungeeCord) the CPU (i7-4770, 32GB/RAM) reports less then 50% usage, Disk I/O is high on the write, with peaks at 20MB/s (RAID 1 w/ dual SSD's).

    What could be a possible cause of such an abnormal behavior on some server's?
     
  7. I looked into it further, it seems to be affecting only our Survival server, what happens, basically, is that the server works fine, and then just goes unresponsive for a while, and then comes back, and it keeps doing that, until eventually it will kick everyone, there is no errors at all when it lags, it just uses a bit more CPU, and the TPS goes down to 19, which is not bad for TPS, but, is there any suggestions any of you could have in regards to this? Any ways of knowing what could possibly be causing this?
     
  8. /stoplag did what it says, but I would rather prefer to find a way of what causes the lag at first.

    Any ideas?