Spigot Hawk Anticheat (MC 1.7.10 & 1.8.8) BETA 2008

A free anticheat for legacy versions of Spigot.

  1. Hey there,

    Unfortunately, Hawk is not designed to support any client version other than 1.7.X and 1.8.X. I'm afraid that Hawk is not compatible with your setup. You'll have to choose another anticheat if you want to support the latest Minecraft client. Sorry about that.
     
  2. I really like this anticheat, but the killaura is kinda wonky and so is the block interact stuff. I know that the velocity check is disabled by default, but it's not toooooo bad. It does false though. Also, I don't have a phone so I can't have access to the discord server. As you should know, not everyone has a phone. I recommend changing the security setting to (╯°□°)╯︵ ┻━┻ because it's secure and people without phones can still join.
     
  3. What reach setting will this client be able to detect?
     
  4. I'm not really sure how to respond to this because some clients will compute ranges differently i.e. hitbox/ray distance or player to player distance. Hawk has two reach checks, hitbox and reach approximate. Honestly you'll just have to test for yourself since hacked clients are inconsistent. Sorry about that.

    However, the hitbox/ray intersection check allows up to 3.1 blocks by default. The reach approximate check (player to player) allows up to 4.0 by default.
     
    • Like Like x 1
  5. Thank you for the fast reply, I will try to see for myself testing different clients, this anticheat really is something incredible on the market, huh.
     
  6. Another question, for the ProtocolSupport, if I'm using a 1.8.8 spigot, and using ProtocolSupport, will that be okay for this anticheat. Since I assume you mean for versions 1.9 and above.
     
  7. It should work as long as your players are running 1.7.x or 1.8.x.
     
    • Like Like x 1
  8. Islandscout updated Hawk Anticheat (MC 1.7.10 & 1.8.8) [REWRITTEN] with a new update entry:

    Attention to Liquids & Other Improvements

    Read the rest of this update entry...
     
  9. Islandscout updated Hawk Anticheat (MC 1.7.10 & 1.8.8) [REWRITTEN] with a new update entry:

    Improvements and Bugfixes

    Read the rest of this update entry...
     
  10. Islandscout updated Hawk Anticheat (MC 1.7.10 & 1.8.8) [REWRITTEN] with a new update entry:

    Configuration Changes & Bugfixes

    Read the rest of this update entry...
     
  11. Islandscout updated Hawk Anticheat (MC 1.7.10 & 1.8.8) [REWRITTEN] with a new update entry:

    Slight changes, improvements, and bugfixes

    Read the rest of this update entry...
     
  12. What are the permission nodes? Hawk.notify and hawk.alerts both don't work :(
     
  13. Yeah, those are the permission nodes. Someone on the discord server with the same username as you said that they just fixed it. I'm assuming that's you. lol
     
  14. before I get this plugin, based on the reviews... Is there much editing within the plugin I need to do? Or can i just add it, and the hacking is some what taken care of?
     
  15. It should work right out of the box. Of course, you might need to fine-tune a few values in the configuration; most likely the tickrate check. However, there are no explanations about the values in the configuration, although I'll work on the wiki soon to provide users with documentation.
     
    • Agree Agree x 1
  16. Islandscout updated Hawk Anticheat (MC 1.7.10 & 1.8.8) with a new update entry:

    More improvements

    Read the rest of this update entry...
     
  17. Islandscout updated Hawk Anticheat (MC 1.7.10 & 1.8.8) with a new update entry:

    Bugfixes and improvements

    Read the rest of this update entry...
     
  18. Please add Anti players ESP. It will be really helpfull!