Help asap

Discussion in 'Spigot Help' started by DimoKouli, May 27, 2015.

  1. I've recently changed craftbukkit with spigot everything seems to work fine and /pl shows all the plugins as loaded but when i type a command for exaple /gmc it says unknown command this happenes for all the plugins but they are shown with green letters...
     
  2. Every single plugin command doesn't work? o.o No clue why that'd be

    What do the following commands tell you?:
    /version
    /version essentials
    /? gmc


    When you switched from craftbukkit to spigot, were you going from 1.7 to 1.8 or were you using the 1.8 craftbukkit jar?
     
  3. its weird i got spigot.jar in but it says craftbukkit 1.7.10
     
  4. If you didn't build the jar yourself using BuildTools, I recommend not using that jar anymore D: It might've had its contents poisoned

    Your best bet is to use the latest BuildTools and get a brand new spigot-1.8.6.jar
     
  5. I would really appreciate if u could help me build it for 1.7 versions.. all of them
     
  6. I'm not sure how to get those older versions D:
    Sorry o.o
     
  7. so i cant make a server that support all 1.7 vers anymore?
     
  8. Unless you can somehow locate the jars, but I think all of the old 1.7 jars are in the legal red-zone 'cuz of the DMCA

    I could be wrong though. I have no clue which versions the legal bullcrap affects, probably safe to assume it's all 1.7 versions though
     
  9. What you can do is make a 1.8.6 server, highly recommended it, and then install a plugin which supports previous versions of minecraft. In all I highly doubt you can get 1.7 versions of bukkit or spigot.
     
  10. Option 2 instead of switching to 1.8.6 is to go back to your old craftbukkit jars assuming they work. But like Vidsify said, going to 1.8.6 is recommended since it's the most up-to-date.
     
  11. When you said your version says this, what does it exactly say?
    This is from a clean 1.7.10 spigot.jar's /version command:
    Code (Text):
    This server is running CraftBukkit version git-Spigot-1649 (MC: 1.7.10) (Implementing API version 1.7.10-R0.1-SNAPSHOT)
     
  12. @ElieTGM I put the most recent version of 1.7.10 removed craft bukkit and now my server wont start..