Help Getting Started

Discussion in 'Hosting Advice' started by Zippy96, Mar 1, 2018.

  1. Hey,

    So my irl friend and I have put together to purchase a cheap dedi from ramnode, Our aim is to run a small server with 3 gamemodes. Now, although we have previous experience in helping to run a server, starting one up ourselves is a first, and needless to stay we've reached a point where we're a little out of our depth.

    Along with the dedi we have Filezilla and PuTTY downloaded, both of which we're familiar with. We know our IP and hostname etc. Running on CentOS 7. We have spigot 1.8 added and we have a startup script. The problems we're having is how can we connect using something like 'play.servername.com', although we have tried connecting with the numerical IP alone, that doesn't seem to work as the only port we had failed to bind... as I said, out of our depth, or maybe we're just dumb af and are missing something obvious. :(

    If someone could assist us it would be greatly appreciated. If we could do it over Discord that would be even better. (ZipsterT#9891)

    Thank you in advance!
     
  2. Where you register your domain, it probably handles your DNS.

    Go to the name server stuff and add an IN A record for play.
    It will then be play.yourdomain.com
    Point the IN A record for play to the unique public IP of the minecraft server.

    Done..

    it can take up to 72 hours to spread around the world, this name server change.
    You can check here: cachecheck.opendns.com
    (and request an update) to see if it is pointing to the right ip (after you changed it, say 5m later)
     
    • Informative Informative x 1
  3. Thank you so much! I have done that now.

    The only problem I'm having now is actually getting the server to start lol. What would the port be, or where would I find it?
     
  4. You can choose any port you want as long as it's not already used or it's higher than ~6500
     
    • Like Like x 1
  5. The default port for minecraft is 25565, however, the server.properties files will tell you that port, and you can change it there as well.

    If your IP works, if your port is opened in the firewall, (you can use ufw and open mc's port, the website's port, and the ssh port) and your host (domain) works, then it's a matter of connecting to the host/ip (default port is optional) or if you change the port to go to play.example.com:12345 (that port goes after : - no spaces)

    Also change the root password, make a new regular user and add it to the sudo group. And another regular user with no sudo powers and just use that for minecraft.

    Then disable root login on ssh and use the sudo-user to remote login with ssh and sudo su up.
    You can change the ssh port as well (but make sure you open the port in the firewall first of course).
     
  6. hey :p you got close.. off by about 60,000 :p

    (2^16)-1 range. (1-65535)

    port 0 is unavailable and reserved.
    port 1 to 1023 are privileged, you shouldn't use these.

    For MC you can use any *available* port between 1024 and 65,535.

    Mc's default port is 25565 (and players don't have to enter this one if they just enter the ip or the host)

    ssh is usually 22
    http is usually 80
    https is usually 443

    etc.

    Using 25565 for your live server is easy for everybody, they dont have to remember a port number.
    Using 35565 is just changing the 2 to a 3, and handy for an internal clone/test setup.
     
  7. Thank you for your replies.

    I'm at a loss. I've used the port 35565 and it started up fine, however, I still can't connect to it. I've tried play.name.com/play.name.com;port/numericalIP;port... nothing. I'm assuming something else is wrong or I've missed something?
     
    #7 Zippy96, Mar 1, 2018
    Last edited: Mar 1, 2018
  8. Because you used the wrong port and didn’t setup an SRV record which you need if your port isn’t 25565.
     
  9. I've done this too. Still can't connect, says 'Can't resolve hostname'.
     
  10. LMAO
    Missed a 0 :D
     
    • Friendly Friendly x 1
  11. Because they are all wrong.

    Let's take a step back and look at the actual file: server.properties
    Find the port it is set to.

    If you use a firewall, make sure that port is added to it for incoming and outgoing traffic for at least TCP.

    If this is on a home computer, you have to port-forward the port to as well.

    If it is 25565

    Then the syntax is: IP:25565

    replace IP with the unique IP or the hostname

    if you use a hostname, check on your computer first if it resolves back to the unique IP.

    example.com
    resolves to 123.123.123.123
    And the server is supposed to run on 123.123.123.123
    Then everything is ok

    Then connect to 123.123.123.123:25565
    or example.com:25565

    The port 35566?
    Ok .. ip:35566 or host:35566

    So, make sure you KNOW the port it's running on by checking server.properties.
    And that you CAN connect to it remotely by properly configuring the network.
    If you're using a HOST, make sure it resolves properly to the IP the java server is bind to.

    Also, check your process list, maybe it's already running, maybe it isn't running minecraft.
    Make sure of course that you have the server started. And that it is running.
     
  12. Progress... I'm finally connected. Thank you so much. I believe it was the firewall issue, so port 35565 is now open.

    With that said, I am only able to connect using IP:35565 and not play.name.com or play.name.com:35565. Not sure what may be causing this.
     
  13. Use nslookup or dig or host or whatever resolves a host to an ip on your system.

    Make sure the returned IP is the one you set the IN A record for.
    You can enter the host here: https://cachecheck.opendns.com/
    and see if the return IP matches what you're getting..
    ns updates require time to propagate. Screen Shot 2018-03-01 at 18.14.04.png
     
  14. Yes, I used nslookup and entered play.name.com and the returned IP matches the one I set for the IN A record.

    I guess then it's just a matter of waiting to see if this resolves itself?
     
  15. We got a VDS (Virtual Dedicated Server)

    Sure, I'll send you these via PM as I'd rather not make it public right now.
     
  16. You get a VPS, you get to use your own IP, so all ports are available. It's not shared hosting. Not sure what you're talkin about.. in that example it would mean they can have 1 customer with a website on port 80, and everybody else has to use a different port. nonsense of course.
     
  17. One thing I noticed is that the IN A record for the domain to the IP is there.
    And that there's a srv record for the host to the internal setup on port 25565
    So when you do domain:25565 it will connect, as it will end up on internal server, port 35565
    So using the IP on 35565 will work, because that just IN A forwards to the internal ip on port 35565 properly.
    What won't work is the IP on 25565 to connect to the internal one on 35565. A redirect has to be added for that, like another srv record or whatever works.

    host:25565
    host:35565
    ip:35565
    works
    doesn't work: ip:25565
     
  18. So now I'm at the point where I have gone with the default 25565 port and removed the srv for 35565. I am able to connect now just by using play.name.com. However, mrfloris could only connect using 'play.name.com:25565' but not 'play.name.com'. This is really frustrating.

    We've tried everything we can think of but if anyone has any ideas as to what else might be causing this please let me know.

    Thanks @mrfloris for your help and your patience.
     
  19. Well, to avoid confusion.

    I was not able to connect with the host, even though it resolves just fine at google/opendns to the right ip and it's fine on my system as well.

    I can however connect with the IP, and the ip to the port.

    @op was able to connect with the host, i couldn't. so strange!

    I saw the dns etc, and everything really appears to be configured correctly.
     
    • Like Like x 1
  20. For me it’s working and i can join using play.name.com
     
    • Like Like x 1

Share This Page