Solved HELP - Items disappearing from chests with no block data.. and more..

Discussion in 'Spigot Help' started by PiggiesGoSqueal, Apr 23, 2017.

  1. Please help! I have absolutely no clue what is causing these issues and they've now happened more than once so I need to figure it out. The first issue is items will sometimes randomly disappear from chests and there is NO block data (using CoreProtect) as to where the items have gone.

    The second issue is some items won't stack for players. For example, they will have 16 sand in one slot of their inventory and 16 sand in another slot then try to combine them into 1 slot and it won't work. This apparently happens in chests, inventories, etc. No one has access to OP commands or worldedit so the items are not disappearing from abuse of commands. For the stacking command the player that has reported the issue said it first happened with named eggs called "Hoppy Easter 2017" eggs. But now has issues with other items. I just tried doing it with the items too and they don't stack for me either. Specifically, the items are: string, spider eyes, rotten flesh, bones, ... probably all or most mob drops at this point.

    Oh.. and one more issue that I've just found. This message is showing up in console repeatedly. How can I fix? http://prntscr.com/ezpzzq

    My server is a 1.10 Spigot server.

    Plugins:
    http://prntscr.com/ezq1xt
    Please don't make comments like "Wow your server must lag a ton with all those plugins". It doesn't lag at all and there are no issues with so many plugins. Besides the issues above, of course, but not sure if they are from plugins. Just tired of hearing that from players whenever I list my plugins. Thanks :)

    Edit: It's probably one of the plugins below but I need to figure out which. These plugins have access to chests. This was discovered thanks to @WAS so thank you for that!
    OldCombatMechanics 1.4.0
    WorldGuard 6.1.2
    ChestShop 3.8.12
    mcMMO
    Authenticator 2.0.4
    AutomaticInventory 2.7.1

    I doubt it's worldguard, chestshop, or mcmmo because those I've had since I started my server and didn't have these issues that entire time. Which leaves the following:
    Authenticator 2.0.4
    AutomaticInventory 2.7.1
    OldCombatMechanics 1.4.0

    Edit:
    The remaining plugins suspected of causing this issue are-

    - AutomaticInventory 2.7.1
    - OldCombatMechanics 1.4.0
     
    #1 PiggiesGoSqueal, Apr 23, 2017
    Last edited: May 14, 2017
  2. Had similar problems with a plugin which removes/changes nbt-data against exploits in creative mode. In my case it was caused by ItemFixer.
     
  3. Hm strange. I do have PerWorldInventory which I use to prevent players from bringing creative items from the Creative world into the Survival world. Except I think the issues started happening before this was added.
     
  4. WAS

    WAS

    Maybe you can log the event, and find out what all access it?
     
  5. I don't understand what you meant sorry. Could you please rephrase that?
     
  6. WAS

    WAS

    Sorry. It is more of an advanced debugging method involving a plugin.

    The following attached plugin will listen on InventoryOpenEvent, determine if it's a chest, and than tell you what plugins have access to this event.

    You can drop it in your plugins folder, and go access a chest, and it'll print (in the console) all the plugins that have access.

    This will give you an idea of if any plugins accessing chests/inventories may cause the issue, and what plugins to look into.

    [​IMG]
     

    Attached Files:

    #8 WAS, Apr 29, 2017
    Last edited: Apr 29, 2017
    • Friendly Friendly x 1
  7. Oh okay. Thanks! :)

    Edit: These are the plugins that showed up in console:
    OldCombatMechanics 1.4.0
    WorldGuard 6.1.2
    ChestShop 3.8.12
    mcMMO
    Authenticator 2.0.4
    AutomaticInventory 2.7.1
    ChestMonitor

    And out of those some have been on the server before the issue started happening. So if you remove those the plugins to choose from for this issue are:
    OldCombatMechanics 1.4.0
    Authenticator 2.0.4
    AutomaticInventory 2.7.1
     
    #9 PiggiesGoSqueal, Apr 29, 2017
    Last edited: Apr 30, 2017
  8. WAS

    WAS

    That "AutmoaticInventory" seems questionable considering the issue. No?

    What does this thing do? Lol
     
  9. Yeah.. That's my main guess so far. AutomaticInventory sorts items in player's inventories and chests. It can also deposit all the items from a player's inventory (not hot bar) into nearby chests with the same items. Another thing it does is replaces items in your hot bar if they get used up. For example, let's say you have 3 stone pickaxes in your inventory (not hot bar) and 1 stone pickaxe in your hot bar. Then while you're mining the stone pickaxe you're using breaks. AutomaticInventory will take one of the pickaxes from your inventory and put it in your hot bar so you can continue mining. It's a very useful plugin. And probably my favorite plugin. Which is why it would be so hard to part with :(

    Also the player reporting the issues with items disappearing from her chests has the automatic sorting disabled for chests and her inventory. Which makes it a bit weird she would have the issue when it's toggled off for her.

    Edit: Hmm.. But I asked her if she used any of the commands or perks from this plugin right before the items disappeared and she said she thinks the server didn't have the plugin when it first happened. Or before it was added as a donor perk.
     
    #11 PiggiesGoSqueal, Apr 30, 2017
    Last edited: Apr 30, 2017
    • Like Like x 1
  10. WAS

    WAS

    I wonder if the disabling of automatic inventories for chests sets that specific event cancelled when it encounters a player with that setting, which may interfere with another plugin than using that event? Just speculation here.
     
  11. Yeah I wondered if disabling it was the cause of the issue but couldn't think of a reason that would be. However, I just found this plugin:
    https://www.spigotmc.org/resources/automaticinventory.34523/ which I think is a more updated version of the plugin I currently use. So maybe I'll try this out and see if it fixes the issue. Although, it takes a very very long time to see whether or not it works :p because the issue is pretty random for when it occurs.