Help Please: Unable to access jarfile BuildTools.jar

Discussion in 'Spigot Help' started by pitsbrgparatrpr, Aug 11, 2016.

  1. Hello! I am trying to create a new .jar file for Spigot. I did this a while back with no issue. I have Bitbash, I have the latest java, and I grabbed the jar file from the page that gives you the info for this on spigot. I right clicked in the area the file is in, the window opened up and I ran the command. But I keep getting the following below. The only difference is I now have Windows 10 if that matters? The .jar file is sitting right in that folder.
    My [email protected] MINGW64 ~/Documents/Gaming/Minecraft
    $ java -jar BuildTools.jar
    Error: Unable to access jarfile BuildTools.jar

    My [email protected] MINGW64 ~/Documents/Gaming/Minecraft
    $
    Not sure what I'm doing wrong? Any help please, thanks! I'm no expert!
     
  2. you need to download buildtools, then download the Git, open the file containing build tools with git, then execute the command.

    Code (Text):
    java -jar BuildTools.jar --rev <VERSION WANTED>
    wait till build tools completes and your done. If it saids

    'could not find BuildTools.jar' try placing a path to the build tools before 'BuildTools.jar'

    Code (Text):
    java -jar c:\Drive\Users\Name\Gaming\Minecraft\BuildToolsFile\BuildTools.jar --rev 1.8.8
     
  3. Thanks.
    I already had Git from a few months ago? And I downloaded Buildtools, the .jar for that is in the file I am opening git in (right clicking on the folder it is in per the instructions then choosing GitBash Here. But it tells me "could not find buildtools.jar".
    The only thing I did not do was a version? I didnt do --rev? I wanted the latest version? So could that be the issue? And if so, do I need to see what the latest version is and put that number in, or is there a generic way to get the latest version.
     
  4. Is BuildTools.jar in ~/Documents/Gaming/Minecraft and named BuildTools.jar
     
  5. Yep! I'm right clicking that window and opening Gitbash there. The command line at the top of Git, shows the directory as such, and the file is sitting right there and has a Git icon symbol.
    Then I'm doing this exactly: java -jar BuildTools.jar
    Only thing I did not include was a version?
     
  6. If you don't include one, it does the latest stable one.
     
  7. I actually ran java -jar spigot.jar and that worked, as that file is there also. The Git I am using is from 4-5 months ago, unless I need a newer version? and the buildtools is straight from the link on Spigot.
     
  8. I deleted Git, and downloaded an updated version, its now running to create the spigot.jar. Must have been something to do with old version?
    thanks for all your help!
     
  9. One more question please. The file is ready, is its called spigot-1.10.2.jar. I was going to drop it in my fttp server file where the old Spigot was. When I did this is the past it just replaced it and it was up to date .. but the old one is called just "spigot.jar", not what the new one is. Should I rename the new one to match the old, and place it in, or delete the old one then let this in with the new name? Was not sure if it would recognize the different name?
    Thanks! This should be my last issue!!