Help Plz Help Meh

Discussion in 'Spigot Plugin Help' started by MR_KMG, May 6, 2015.

  1. So i try to run a spigot server on my mac but then this happens

    Last login: Wed May 6 20:52:02 on ttys000

    josephs-MacBook-Air:~ joseph$ /Users/(Name)/Desktop/Server/start.command ; exit;

    Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=128M; support was removed in 8.0

    Loading libraries, please wait...

    [21:12:20 INFO]: Starting minecraft server version 1.8.3

    [21:12:20 INFO]: Loading properties

    [21:12:20 INFO]: Default game type: SURVIVAL

    [21:12:20 INFO]: This server is running CraftBukkit version git-Spigot-2f787bd-ea28011 (MC: 1.8.3) (Implementing API version 1.8.3-R0.1-SNAPSHOT)

    [21:12:21 INFO]: Debug logging is disabled

    [21:12:21 INFO]: Server Ping Player Sample Count: 12

    [21:12:21 INFO]: Using 4 threads for Netty based IO

    [21:12:21 INFO]: Generating keypair

    [21:12:21 INFO]: Starting Minecraft server on (My Ip):34465

    [21:12:21 INFO]: Using default channel type

    [21:12:21 WARN]: **** FAILED TO BIND TO PORT!

    [21:12:21 WARN]: The exception was: java.net.BindException: Can't assign requested address

    [21:12:21 WARN]: Perhaps a server is already running on that port?

    [21:12:21 INFO]: Stopping server

    [21:12:21 INFO]: Saving players

    >logout



    [Process completed]

    Yes I'm on a mac and yes i know how to port forward but it seems not to be working i also tried 25565 then i tried 34465 to see if [21:12:21 WARN]: Perhaps a server is already running on that port? was true
     
  2. Tao

    Tao
    Benefactor

    Try eliminating some of the obvious, have you checked that that's the right port, made sure you didn't type it wrong? Eliminate some of the general possibilities that add on to this thread.
    Hope that helped at least a bit.
     
  3. This has happened to me before just because of a basic "Another" instance of java running, i just opened my task manager and ended ajava task and then tried again and it worked.