Help with a Inventory Bug

Discussion in 'Spigot Discussion' started by crysis992, May 13, 2013.

  1. Hey guys,

    I have a little bug on my server since few weeks, and im unsure how to fix it or what is causing it.
    About the bug, not every player has this bug, just 2 of 3 players are complaining.

    If a player want to place a block, its turning into a random block, lets say i want to place a crafting table, sometimes the placed block turns into sand or log. If i craft something, Items/blocks are moving randomly in the inventory or just disappearing from the inventory, a relog fixes this, after a relog the inventory is back to normal, but its annoying to relog every 5 minutes.

    I tried different Spigot and Bukkit builds. I deleted all player.dat files to make sure its not a corrupted player file. All my plugins are up-to-date.

    Any ideas how to solve this bug/problem?
     
    • Agree Agree x 1
  2. externo6

    Supporter

    What plugins do you have installed?
     
  3. My Plugin list:

    AvalonCore,BookRules,BuyRegion,CraftConomy,Essentials,Herochat,KrimBuy,Lockette,Logblock,MaxBans,MineQuery,Multiverse,NoChatPlus,PermissiosEx,PluginManager,PermissionShop,St0rmirc,Vault,Votifier,WorldBorder,WorldEdit,WorldGuard,xAuth

    But i dont think so any of these plugins is causing it, else I would have found any results to this problem on google :p
     
  4. What version of spigot do you have?

    Does this occur if you run without any plugins?
     
  5. LiLChris

    LiLChris Retired Moderator
    Retired

    I bet its xAuth. ;)

    No this isn't a fight for online mode...
     
    • Funny Funny x 1
  6. Dabo Ross:
    Running at the moment on build 850 (latest), but actually this happens on evey build since i updated to 1.5
    And yes, it occur without any plugins too, but not that often. Like i said, its randomly and not for every player :/
    Just like 50% of my players have this bug.
     
  7. So if you run it without any plugins for a while and people join, they still have this bug?

    If it was any of the plugins I would think it would be one of them that edits inventory, like multiverse/essentials/xauth.

    When this happens to them, do they have both the block that they should have placed and the block that appeared in their inventory? And if they did have the block that appeared in their inventory then did the quantity of that block decrease?

    Or did the quantity of the block that they meant to place decrease?

    Also do you see the same item in their hand as they do right before this happens?
     
  8. Lets say player x has 15 log, 20 sand, 5 cobble and a crafting table in the inventory. Player x tries to place a crafting table, but instead of a crafting table, the "Item in Hand" randomly switches to one of the other items, and it places this item. The quantity of the random item decrease, and the Crafting table turns invisible till they relog.

    I have no idea what would cause such a bug (For some reason its just for normal players, Operators are not affected at all).

    Also tested yesterday, if its a corrupted worldfile, so i generated a new world, just to test. Players also had the bug on the new world.
     
  9. It seems like the client and server are not synced up, inventory wise. I have seen this as an issue with some plugins, like ones that are supposed to add an item to your inventory. Sometimes the item will not show up until you move some items around to update the inventory. I am not sure what would cause a crafting tabe to do this, because usually it happens when something replaces the item slot of another item.
     
  10. When the 'item in hand' switches, do you mean that the slot that they have selected switches from say slot 1 to slot 4, or that the item in slot 4 switches with the item in slot 1?

    In any case it is probably caused by an unsynchronization of the server and the client. Does this occur with netty disabled?
     
  11. The Item in hand randomly switchtes to another slot in the inventory or hotbar. Also, its not just crafting tables causing this bug. Today another player reported, he tried to craft sticks, took the sticks out of the crafting table, and got logs in the inventory. Or recently, a player tried to place logs, they were not visible the player relogged. (Disappearing on his screen) but the logs were visible on my screen.

    I'll try to get a video of this bug :/ Or i can PM you the server adress to test it yourself if you want (if it happens then(its happens randomly like i said)).

    I'm not sure if it occur with netty disabled. I'm running the server via mcmyadmin, and i have no idea how to disable netty with mcmyadmin.
     
  12. So the slot that is selected stays the same but another item is put there?


    To disable netty you would add this jvm flag to your startup command:
    Code (Text):
    -Dorg.spigotmc.netty.disabled=true
    putting that before the -jar option.
    I am not sure how to do this in mcmyadmin though think I think there should be an option for java flags.

    If it still doesn't work with netty disabled, try starting up a server with a freshly downloaded spigot.jar file (in a new folder/directory), no wrappers, no plugins, no config options, and a simple java start script like:
    Code (Text):
    java -jar spigot.jar
    Just to test if it still occurs (when doing this you don't need to make any changes to your regular server).
     
  13. Okay, here is a video of the bug(Sorry for bad quality)


    Im going to try it now with netty disabled, and report/edit this post in few hours or tomorrow.
     
  14. If someone who has this happen makes a crafting table, puts it in their inventory, then logs off and logs back on, do they still have the crafting table in the same place?
     
  15. Not always, but most of the time, they have a "normal" inventory after a relog.
    But like you see at the end of my video, the crafting table i had in my inventory and placed down, was gone after a relog and it added back the logs/wooden planks i used to craft the table with.

    Also tested it with netty disabled, it seems this fixed the bug, not happend in the last 5 hours.
    I'll ask my players to make sure it didnt happen and reply in few hours.