Help with BiteSkyWars Kits!

Discussion in 'Spigot Plugin Help' started by WhenChickensFly0, May 15, 2017.

  1. Whenever I copy the default kit and modify it it says this:
    [18:00:59 ERROR]: Error occurred while enabling BiteSkyWars v1.1.9 (Is it up to date?)

    java.lang.NullPointerException

    at org.bukkit.ChatColor.translateAlternateColorCodes(ChatColor.java:210) ~[craftbukkit-1.11.jar:git-Bukkit-0a81101]

    at net.spikybite.ProxyCode.utils.SwUtil.color(SwUtil.java:58) ~[?:?]

    at net.spikybite.ProxyCode.gamesutils.GameKit.<init>(GameKit.java:40) ~[?:?]

    at net.spikybite.ProxyCode.SkyWars.createKits(SkyWars.java:457) ~[?:?]

    at net.spikybite.ProxyCode.SkyWars.onEnable(SkyWars.java:171) ~[?:?]

    at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:271) ~[craftbukkit-1.11.jar:git-Bukkit-0a81101]

    at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:329) [craftbukkit-1.11.jar:git-Bukkit-0a81101]

    at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:404) [craftbukkit-1.11.jar:git-Bukkit-0a81101]

    at org.bukkit.craftbukkit.v1_11_R1.CraftServer.enablePlugin(CraftServer.java:360) [craftbukkit-1.11.jar:git-Bukkit-0a81101]

    at org.bukkit.craftbukkit.v1_11_R1.CraftServer.enablePlugins(CraftServer.java:322) [craftbukkit-1.11.jar:git-Bukkit-0a81101]

    at net.minecraft.server.v1_11_R1.MinecraftServer.t(MinecraftServer.java:411) [craftbukkit-1.11.jar:git-Bukkit-0a81101]

    at net.minecraft.server.v1_11_R1.MinecraftServer.l(MinecraftServer.java:372) [craftbukkit-1.11.jar:git-Bukkit-0a81101]

    at net.minecraft.server.v1_11_R1.MinecraftServer.a(MinecraftServer.java:327) [craftbukkit-1.11.jar:git-Bukkit-0a81101]

    at net.minecraft.server.v1_11_R1.DedicatedServer.init(DedicatedServer.java:244) [craftbukkit-1.11.jar:git-Bukkit-0a81101]

    at net.minecraft.server.v1_11_R1.MinecraftServer.run(MinecraftServer.java:521) [craftbukkit-1.11.jar:git-Bukkit-0a81101]

    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_121]

    Here is my kit code:
    ## cost is equals '0' is FREE ##
    cost: 150
    ## Name blocked and unblocked kit ##
    name: "&aArcher”
    nameBlocked: "&cArcher”
    ## Item Blocked and UnBlocked kit ##
    item-unlock: "261,1,0”
    item-lock: "160,1,14"
    ## Lore unblock and blocked kit ##
    lore-unlock:
    - "&eYou can select this kit"
    - "&eContains:"
    - "&7- &bx1 Bow”
    - "&7- &bx20 Arrow”
    lore-lock:
    - "&cThis kit has blocked for you"
    ## Items List ##
    item-list:
    - "261,1,0,name:&eArcher,”
    - “262,20,0,name:&eArcher,”
    slot: 2

    I'm running my bucket server on Mac.

    Any help will be appreciated!
     
    #1 WhenChickensFly0, May 15, 2017
    Last edited: May 15, 2017
  2. It doesn't seem to get the "name" string:

    NullPointerException, at net.spikybite.ProxyCode.gamesutils.GameKit.<init>(GameKit.java:40) ~[?:?],
    Code at that line: this.nameKit = SwUtil.color(this.config.getString("name"));

    Did you reload the plugin after you modified the file?
     
    • Agree Agree x 2
  3. What do you mean by reload?
     
    • Agree Agree x 1
  4. Like with /reload or using the plugin internal reload command
     
    • Agree Agree x 1
  5. No I did not, it said it would cause errors.
     
  6. You mean the "Please note that this command may cause issues" thing?
    It doesn't say that it will cause issues, just that i may cause issues (Some plugins can have problems when they are reloaded using /reload)
    You have to reload the plugin in order to apply the changes to the config (alternatively you can restart your server)
     
    #6 MrLetsplay, May 17, 2017
    Last edited: May 17, 2017
    • Agree Agree x 1
  7. I did restart the server, that is how the issues started, they popped up when it enabled the plugin.
     
  8. Thanks for your help anyway.
     
  9. I don`t really like BiteSkyWars but, if you send me an email for [email protected] i will give you a much better plugin