Help with GLIBC please?

Discussion in 'Server & Community Management' started by Danrique, May 13, 2020.

  1. I am Installing multicraft and all was ok until the final step on the panel where you have to
    Detected Daemons

    I run the command on putty "multicraft/bin/multicraft start" in the correct folder and this erros shows... I am new on this things so, any help is apreciated!

    [[email protected] multicraft]# /root/multicraft/bin/multicraft start
    /root/multicraft/bin/multicraft: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /root/multicraft/bin/multicraft)
    /root/multicraft/bin/multicraft: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /root/multicraft/bin/libpython2.7.so.1.0)
    /root/multicraft/bin/multicraft: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /root/multicraft/bin/libstdc++.so.6)
    /root/multicraft/bin/multicraft: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /root/multicraft/bin/libgcc_s.so.1)

    What should I do? Is a private virtual machine that I rented.

    Edit: I did this commands


    mkdir ~/glibc_install; cd ~/glibc_install

    wget http://ftp.gnu.org/gnu/glibc/glibc-2.14.tar.gz

    tar zxvf glibc-2.14.tar.gz

    cd glibc-2.14

    mkdir build

    cd build

    ../configure --prefix=/opt/glibc-2.14

    make -j4

    sudo make install

    export LD_LIBRARY_PATH="/opt/glibc-2.14/lib${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}"

    Now there is only one error

    ImportError: /opt/glibc-2.14/lib/libc.so.6: version `GLIBC_2.17' not found (required by /root/multicraft/bin/libssl.so.10)

    If I install 2.17, the errors I got first appears again asking for 2.14....
     
    #1 Danrique, May 13, 2020
    Last edited: May 13, 2020