Help with IntellIj remote debug?

Discussion in 'Spigot Plugin Development' started by Perotin, Jul 7, 2018.

  1. Hello, I was following along with this wiki https://www.spigotmc.org/wiki/intellij-debug-your-plugin/ and I did everything it said, was able to connect to my rermote server, but when I tried to run it I got this

    Screen Shot 2018-07-07 at 4.13.52 PM.png

    "Cannot find runner for Server runner"

    Here is what my runner config looks like
    Screen Shot 2018-07-07 at 4.15.20 PM.png

    I am also using Maven, so if there are some maven commands I should be running pre-compilation please let me know.

    Thanks
     
  2. Benz56

    Moderator Supporter

    Could you post your start BAT file?

    Should look something like this:
    Code (Text):
    @echo off
    title Benz56 Server Console
    java -Xms512M -Xmx4G -DIReallyKnowWhatIAmDoingISwear -agentlib:jdwp=transport=dt_socket,server=y,suspend=n,address=5005 -jar spigot-1.12.2.jar
    PAUSE
    Ignore the -DIReallyKnowWhatIAmDoingISwear property; I'm lazy lol.
     
    • Agree Agree x 1
    • Funny Funny x 1
  3. Code (Text):
    #!/bin/sh

    cd "$( dirname "$0" )"
    java -Xmx2G -Xms2G -agentlib:jdwp=transport=dt_socket,server=y,suspend=n,address=5005 -jar ./spigot.jar
     
    I'm on mac, so its a little different but I think that should be the equivalent no?

    P.S. Jesus another mod! Congratulations :)
     
  4. Benz56

    Moderator Supporter

    Hmm, I am no Mac expert, however, you can take a look at my setup; perhaps you'll notice something:
    [​IMG]

    Thanks, @Perotin ! ;)
     
  5. Thanks for the help, nothing really stands out except that my JVM args are in a drop down like so:
    Screen Shot 2018-07-07 at 6.20.09 PM.png

    Another thing I noticed is that if I change it to 1.3.x or 1.4.x it gets reset back to 5-8. Though I don't think that makes much difference either as I've hit run from that window on those specific settings and still got the same result.