Help with plugin syntax errors?

Discussion in 'Spigot Plugin Development' started by Jeremaster101, Jun 22, 2018.

  1. Hello. I have made a minigame about 3 years ago for Minecraft 1.7. Everything worked fine then, and I received no errors inside of eclipse. Now I was going to use this plugin again with 1.12 and the latest version of java. I have fixed as many errors as I could, but I am totally stumped on a few errors. These errors were not there when I made it in 1.7, and they now prevent my onPlayerInteract events from occurring. Please ignore the comments before each line, as I had lost the source code and I needed to decompile the jar I saved. I commented in what errors eclipse was giving me.

    (Code was too long to post so I linked to a pastebin paste)

    https://pastebin.com/iEGLBtta
     
  2. Could you please also provide the error message you get when running this code?