Hi, Im trying to use viaversion to add 1.17 support to my 1.16 bungee but its not working

Discussion in 'BungeeCord Plugin Help' started by OwenRLol, Jun 23, 2021.

  1. when I try to join on mc it says Internal Exception: io.netty.handler.codec.DecoderException: com.google.gson.JsonSyntaxException: com.google.gson.stream.MalformedJsonException: Use JsonReader.setLenient(true) to accept malformed JSON at line 1 column 1 path $
    On console it says 23.06 09:34:46 [Server] WARNING Event PermissionCheckEvent(sender=Astronomy_Nerd, permission=viaversion.update, hasPermission=false) took 251ms to process! 23.06 09:34:46 [Server] WARNING Event PostLoginEvent(player=Astronomy_Nerd) took 295ms to process! 23.06 09:34:48 [Server] INFO [Astronomy_Nerd] -> UpstreamBridge has disconnected.
    Does anyone know how to fix this? If so, let me know
    Thanks in advance!
     
  2. U can use 1.17 bungee with 1.16(with viaver) bukkit servers. I think its compatible.
     
  3. none of my servers are 1.16
    one is 1.8 and one is 1.12.2
     
  4. I tried 1.17 bungee and it broke my network