Spigot HoloPlots 5.1.0

Holograms instead of signs for PlotSquared

  1. Empire92 submitted a new resource:

    HoloPlots - Holograms instead of signs for PlotSquared

    Read more about this resource...
     
  2. Really cool idea, but how well is it on performance?
    Wouldnt a multitude of 1k+ plots cause intense entity issues/lag?
     
    • Agree Agree x 2
  3. As said above, how would this run? Correct me if im wrong, holograms are entities?
     
  4. It sends a hologram packet along with the chunk packet. Because I am just sending packets, the entity only exists client side, i.e. the bukkit server doesn't know about the entity. It should be fairly lightweight and doesn't really matter how many plots you have.
     
  5.  
    • Like Like x 1
  6. why dont you just add this as a default disabled option in config?

    #You need Holographic Display and ProtocolLib to run this
    HoloPlots: disable
     
  7. - less unnecessary features bundled with PlotSquared for people who don't want it.
    - It's a lot easier from the development side of things
    - HoloPlots may add hooks for other plot plugins at some later point.
     
  8. okay :) ill download it once my plots are backup.
     
  9. Does it work with plotme?
     
    • Like Like x 1
  10. Not currently. It's planned for when PlotMe 0.17 comes out. In the meantime, why not try out PlotSquared? ;)
     
  11. Ah thanks. And i've already started using plotme :)
     
    • Agree Agree x 1
    • ... 12 more
    • at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_55]
    • at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[Spigot-1.8.x-eula.jar:git-Spigot-2ec6f06-7722428]
    • at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[Spigot-1.8.x-eula.jar:git-Spigot-2ec6f06-7722428]
    • at java.net.URLClassLoader.findClass(Unknown Source) ~[?:1.7.0_55]
    • at java.security.AccessController.doPrivileged(Native Method) ~[?:1.7.0_55]
    • at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_55]
    • Caused by: java.lang.ClassNotFoundException: com.comphenix.protocol.events.PacketListener
    • at java.lang.Thread.run(Unknown Source) [?:1.7.0_55]
    • at net.minecraft.server.v1_8_R2.MinecraftServer.run(MinecraftServer.java:522) [Spigot-1.8.x-eula.jar:git-Spigot-2ec6f06-7722428]
    • at net.minecraft.server.v1_8_R2.DedicatedServer.init(DedicatedServer.java:257) [Spigot-1.8.x-eula.jar:git-Spigot-2ec6f06-7722428]
    • at net.minecraft.server.v1_8_R2.MinecraftServer.a(MinecraftServer.java:337) [Spigot-1.8.x-eula.jar:git-Spigot-2ec6f06-7722428]
    • at net.minecraft.server.v1_8_R2.MinecraftServer.k(MinecraftServer.java:382) [Spigot-1.8.x-eula.jar:git-Spigot-2ec6f06-7722428]
    • at net.minecraft.server.v1_8_R2.MinecraftServer.r(MinecraftServer.java:416) [Spigot-1.8.x-eula.jar:git-Spigot-2ec6f06-7722428]
    • at org.bukkit.craftbukkit.v1_8_R2.CraftServer.enablePlugins(CraftServer.java:316) [Spigot-1.8.x-eula.jar:git-Spigot-2ec6f06-7722428]
    • at org.bukkit.craftbukkit.v1_8_R2.CraftServer.loadPlugin(CraftServer.java:356) [Spigot-1.8.x-eula.jar:git-Spigot-2ec6f06-7722428]
    • at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [Spigot-1.8.x-eula.jar:git-Spigot-2ec6f06-7722428]
    • at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:335) [Spigot-1.8.x-eula.jar:git-Spigot-2ec6f06-7722428]
    • at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) ~[Spigot-1.8.x-eula.jar:git-Spigot-2ec6f06-7722428]
    • at com.empcraft.holoplots.Main.onEnable(Main.java:11) ~[?:?]
    • java.lang.NoClassDefFoundError: com/comphenix/protocol/events/PacketListener
    • [16:25:32] [Server thread/ERROR]: Error occurred while enabling HoloPlots v1.1 (Is it up to date?)
    There is a problem...
     
  12. You need ProtocolLib and HolographicDisplays installed.
     
  13. I would love if it supported PlotMe
     
  14. For some reason I am just recently noticed these errors:
    [13:20:42 WARN]: [HoloPlots] Task #4843 for HoloPlots v2.11 generated an exception
    java.lang.IncompatibleClassChangeError: Expected static method com.intellectualcrafters.plot.PlotSquared.isPlo
    tWorld(Ljava/lang/String; ) Z
    at com.empcraft.holoplots.PSHoloUtil.updatePlayer(PSHoloUtil.java:28) ~[?:?]
    at com.empcraft.holoplots.PacketListener$1$1.run(PacketListener.java:31) ~[?:?]
    at org.bukkit.craftbukkit.v1_8_R3.scheduler.CraftTask.run(CraftTask.java:71) ~[spigot-1.8.7.jar:git-Sp
    igot-44c59bf-8f0f4ed]
    at org.bukkit.craftbukkit.v1_8_R3.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:350
    ) [spigot-1.8.7.jar:git-Spigot-44c59bf-8f0f4ed]
    at net.minecraft.server.v1_8_R3.MinecraftServer.B(MinecraftServer.java:726) [spigot-1.8.7.jar:git-Spig
    ot-44c59bf-8f0f4ed]
    at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:367) [spigot-1.8.7.jar:git-Spig
    ot-44c59bf-8f0f4ed]
    at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:657) [spigot-1.8.7.jar:git-Spig
    ot-44c59bf-8f0f4ed]
    at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:560) [spigot-1.8.7.jar:git-Sp
    igot-44c59bf-8f0f4ed]
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_45]


    Its generation lots and lots of them.

    I cant seem to point out why...
    can you lend a hand Empire92?
     
  15. Is there any way you can fix the known bug? I like the plugin so far.
     
  16. Update HoloPlots.
     
  17. Please update it to get refresh when the plot owner changes or something like that
     
    • Like Like x 1