Spigot Horse Armor [Minecraft 1.16.1] 1.1

Crafting Recipes for Horse Armor and the Saddle

  1. Bartoneye submitted a new resource:

    Horse Armor [Minecraft 1.16.1] - Crafting Recipes for Horse Armor and the Saddle

    Read more about this resource...
     
  2. Hello, I got this Error Message, please check it

    [19:48:25] [Server thread/WARN]: Initializing Legacy Material Support. Unless you have legacy plugins and/or data this is a bug!
    [19:48:27] [Server thread/WARN]: Legacy plugin HorseArmors v1.0 does not specify an api-version.
    [19:48:27] [Server thread/ERROR]: Fatal error trying to convert HorseArmors v1.0:me/Bartoneye/HorseArmors/Main.class
    org.bukkit.plugin.AuthorNagException: No legacy enum constant for DIAMOND_HORSE_ARMOR. Did you forget to define a modern (1.13+) api-version in your plugin.yml?
    at org.bukkit.craftbukkit.v1_16_R1.util.Commodore$1$1.visitFieldInsn(Commodore.java:200) ~[spigot-1.16.1.jar:git-Spigot-ad703da-e2403a3]
    at org.bukkit.craftbukkit.libs.org.objectweb.asm.ClassReader.readCode(ClassReader.java:2415) ~[spigot-1.16.1.jar:git-Spigot-ad703da-e2403a3]
    at org.bukkit.craftbukkit.libs.org.objectweb.asm.ClassReader.readMethod(ClassReader.java:1488) ~[spigot-1.16.1.jar:git-Spigot-ad703da-e2403a3]
    at org.bukkit.craftbukkit.libs.org.objectweb.asm.ClassReader.accept(ClassReader.java:718) ~[spigot-1.16.1.jar:git-Spigot-ad703da-e2403a3]
    at org.bukkit.craftbukkit.libs.org.objectweb.asm.ClassReader.accept(ClassReader.java:401) ~[spigot-1.16.1.jar:git-Spigot-ad703da-e2403a3]
    at org.bukkit.craftbukkit.v1_16_R1.util.Commodore.convert(Commodore.java:131) ~[spigot-1.16.1.jar:git-Spigot-ad703da-e2403a3]
    at org.bukkit.craftbukkit.v1_16_R1.util.CraftMagicNumbers.processClass(CraftMagicNumbers.java:298) ~[spigot-1.16.1.jar:git-Spigot-ad703da-e2403a3]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:140) ~[spigot-1.16.1.jar:git-Spigot-ad703da-e2403a3]
    at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:96) ~[spigot-1.16.1.jar:git-Spigot-ad703da-e2403a3]
    at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_231]
    at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_231]
    at java.lang.Class.forName0(Native Method) ~[?:1.8.0_231]
    at java.lang.Class.forName(Unknown Source) ~[?:1.8.0_231]
    at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:64) ~[spigot-1.16.1.jar:git-Spigot-ad703da-e2403a3]
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[spigot-1.16.1.jar:git-Spigot-ad703da-e2403a3]
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:394) ~[spigot-1.16.1.jar:git-Spigot-ad703da-e2403a3]
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:301) ~[spigot-1.16.1.jar:git-Spigot-ad703da-e2403a3]
    at org.bukkit.craftbukkit.v1_16_R1.CraftServer.loadPlugins(CraftServer.java:380) ~[spigot-1.16.1.jar:git-Spigot-ad703da-e2403a3]
    at net.minecraft.server.v1_16_R1.DedicatedServer.init(DedicatedServer.java:186) ~[spigot-1.16.1.jar:git-Spigot-ad703da-e2403a3]
    at net.minecraft.server.v1_16_R1.MinecraftServer.v(MinecraftServer.java:810) ~[spigot-1.16.1.jar:git-Spigot-ad703da-e2403a3]
    at net.minecraft.server.v1_16_R1.MinecraftServer.lambda$0(MinecraftServer.java:164) ~[spigot-1.16.1.jar:git-Spigot-ad703da-e2403a3]
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_231]
     
  3. Thanks for letting me know. I hadn't had this error message, but I will see what I can do about it.

    Could you tell me about what other plugins you have installed and if you're using 1.16.1 or a previous version?
     
  4. Update: I hadn't added the api-version text to the plugin.yml. I now have, and I have designated it to use the 1.16 api since this is the intended version, and the one I'm currently playing on. I will upload the fix momentarily.