Solved How do I put Unicode chars in essentials msgs

Discussion in 'Spigot Plugin Help' started by 09TheMobLordXx, Feb 8, 2020.

  1. Hello, I am trying to edit the Essentials Locale files and make all messages have this before them
    &8&lThe &b&lVladeCraft &b■ (MESSAGE)
    but when I edit them they appear weirdly in-game with a A symbol before the Unicode symbol I have tried multiple ways to remove the symbol like these below but no avail
    \u00a78\u00a7lThe \u00a7b\u00a7lVladeCraft \u00a7b■ (MESSAGE)
    §8§lThe §b§VladeCraft §b■ (MESSAGE)
     
  2. I don't believe Essentials supports unicode symbols due to how it parses the lang file.
     
  3. I really think they do, another server uses this symbol on all their essential messages.
     
  4. Yes, you're correct. You need to save the file as UTF-8 for the messages to appear.
     
    • Agree Agree x 1
  5. How do I do that
     
  6. I just saved it has that and I restarted my server but it still wont work
     
  7. After I convert it what text do I copy / paste back into the file
     
  8. > "JS/Java/C", but uncheck ES6
     
  9. To do this, I search '<character> FileFormat.info', then scroll down to the 'Encodings' table, then scroll down to 'C/C++/Java source code'.
    The code you are looking for is in the quotation marks: \u00BB which outputs » in Essentials.

    So, for the character you looked for, I searched up '■ FileFormat.info' and clicked on the first link.
    Scrolled down to the Encodings table, then to 'Java source code' and found this for you: \u25A0

    TLDR you put \u25A0 where you want the symbol to go
    Hope this was helpful :)
     
  10. This was so helpful! It fixed the essentials problem, Thank!!
     
  11. Np