How do I setup LiteBans web interface?

Discussion in 'Spigot Plugin Help' started by FlintSpellhunter, Nov 27, 2016.

  1. I've looked everywhere, I need a detailed tutorial on how to do this, can someone link me one or give me a detailed explanation how to install and set it up? Thanks!
     
  2. mathhulk

    mathhulk Retired Moderator
    Retired

    The installation process is right in the plugin's description...
     
  3. I am aware, but it isn't detailed at all. I don't know what I'm doing at all, I need something with more step by step in detail. I'm not a website genius that will read that and go "Oh i know!" I don't even know how to setup a mysql database.
     
  4. mathhulk

    mathhulk Retired Moderator
    Retired

    Do you have a web server, dedicated server, or a VPS?
     
  5. Yes, I have webhosting if that's what you're asking.
     
  6. mathhulk

    mathhulk Retired Moderator
    Retired

  7. mathhulk

    mathhulk Retired Moderator
    Retired

    Anything. Just remember the name you created it under and enter in this name, the user's name, and the user's password when you are setting up the interface.
     
  8. Ok, so I created my database. I also uploaded the files for the plugin to /bans, now when I put my address.com/bans/index.php I'm getting a common 404 error.
     
  9. mathhulk

    mathhulk Retired Moderator
    Retired

    You didn't upload the files to the /bans folder then. Make sure that you uploaded them to public_html/bans/ and that you have correctly forwarded your domain.
     
  10. Ok, so the bans folder wasn't in the public_html folder, I moved it there and I am still getting my 404 error. Everything is in the folder, I double checked. And my domain is forwarded to the site for sure
     
  11. mathhulk

    mathhulk Retired Moderator
    Retired

    Could you link me to your website?
     
  12. Sure, it's on 000webhost but eh, it works. 1337survivalbans.000webhostapp.com/bans/index.php
     
    • Creative Creative x 1
  13. mathhulk

    mathhulk Retired Moderator
    Retired

    That link doesn't seem to work or lead anywhere. The sub-domain itself ("1337survivalbans.000webhostapp.com") doesn't seem to lead anywhere either...
     
  14. Oh, you have to have a www. on the url. I'm not sure why but you do.
     
  15. mathhulk

    mathhulk Retired Moderator
    Retired

    I don't think you uploaded the files correctly. The browser can't find anything anywhere on your web server.
     
    • Useful Useful x 2
  16. [​IMG] Does it seem okay?
     
  17. mathhulk

    mathhulk Retired Moderator
    Retired

    Yeah, that's really weird. You should contact your host.
     
  18. Ok, I set up everything on a completely new host (http://bans.x10host.com/bans/index.php) this time it's working and functional, now I just need to know how to link my server to the site so I can fetch the tables.
     
  19. mathhulk

    mathhulk Retired Moderator
    Retired

    In your LiteBans plugin, set the MySQL database information to the information that you set when you setup your interface.