How do I update Spigot 1.17 with BuildTools?

Discussion in 'Spigot Help' started by bfarmer31, Jun 18, 2021.

  1. Hello,

    After upgrading my server to 1.17 spigot I can't use any inventory commands such as:
    /buy
    /invsee
    /echest

    It crashes the server every time. It seems others have had this problem and the solution for all was to "Rebuild spigot 1.17 with BuildTools". I can't figure out how to do this. Any help would be GREATLY appreciated!!!! :)
    -bFarm
     
  2. I'm using GGservers for hosting.
    I tried reaching out to their Support but it wasn't much help.
     
  3. If it's crashing the server please provide the crash log (on a site like pastebin). The commands that you are using are not part of spigot itself and are likely from a plugin, you should send any errors regarding plugins to their developers.
     
  4. Here are the crash logs:
    https://pastebin.com/L4PbazN3

    Similar issues:
    https://www.spigotmc.org/threads/1-17-crash-on-adding-items-to-custom-inventory.510341/
    https://www.gitmemory.com/issue/Jikoo/OpenInv/26/860040916
    https://www.spigotmc.org/threads/opening-custom-inventory-causes-server-to-crash-in-1-17.510253/
     
  5. I reached out to the Dev support for /buy and they said I needed to update Spigot 1.17 with BuildTools without offering guidance how to do this. I've tried Googling it but am still new to Minecraft and struggling to figure out how to do this.
     
  6. Does this apply though if I'm using a hosting website for my server?
    I tried just putting this in the Console and nothing happened:

    java -jar BuildTools.jar --rev 1.17

    I know I probably sound clueless because I am sorry :(
    I took over this server from a friend and can't figure out much.
     
  7. you build it on your computer, and upload to the host
     
  8. I'll give it a try! Thank you :)
     
    • Friendly Friendly x 1
  9. I'm clueless and couldn't figure it out. Sorry :(
    are there people that do freelance type work for this that I could pay to walk me through this?
     
  10. For more context, this is what it says in the console every time I start my server:

    18.06 11:56:58 [Multicraft] Loaded config for "Spigot 1.17"
    18.06 11:56:58 [Multicraft] Updating eula.txt file
    18.06 11:56:59 [Server] INFO *** Error, this build is outdated ***
    18.06 11:56:59 [Server] INFO *** Please download a new build as per instructions from https://www.spigotmc.org/go/outdated-spigot ***

    ------
    I'm on a Mac
    I went to the website and downloaded Buildtools.jar
    Step 3 says to "navigate to where you downloaded Buildtools.jar - It's in my downloads folder so just open that?
    Step 4 says the terminal command to run two commands. I run them and get this error:

    ~ % java -Xmx2G -jar BuildTools.jar
    Error: Unable to access jarfile BuildTools.jar
     
  11. Do you have Java 16 installed?
     
  12. You need to navigate to your downloads folder via the terminal, you can do that with the cd (change directory) command:
    Code (Text):
    cd ~/Downloads
    You should now be able to run BuildTools correctly. It's recommended to run BuildTools in a separate folder than your main downloads folder because it makes a bunch of folders when ran. For example, to use the folder "buildtools" in your downloads folder, you could first make it via Finder, move the jar file there and finally enter it with cd ~/Downloads/buildtools.
     
  13. All fixed!

    Re-downloaded 1.17 here:
    <illegal distribution redacted>

    Then followed these steps:


    Thank you everyone for the assistance :)
     
    #14 bfarmer31, Jun 18, 2021
    Last edited by a moderator: Jun 18, 2021
  14. "How do I update Spigot 1.17 with BuildTools?"

    How can the title be: how do i use buildtools to update to spigot 1.17

    But the question is: After I updated ...

    Don't use pre-builds, get buildtools.jar and run it from command line, it's the same command as running the server. just 1. Using prebuilds is not recommended for the obvious reasons..