How is TheHive doing this?

Discussion in 'Spigot Discussion' started by Cade, Sep 20, 2013.

Thread Status:
Not open for further replies.
  1. Cade

    Supporter

  2. prplz

    Supporter

    It's quite possible with the new payload in the ping packets that contains the version, they probably had someone make it custom for them.
     
  3. LiLChris

    LiLChris Retired Moderator
    Retired

    Interesting, wouldn't mind that myself.
    The lazy part of me doesn't want to update mods, I wouldn't doubt it thousands of players feel the same way.
     
  4. md_5

    Administrator Developer

    Its about 6 lines of code in BungeeCord. I don't include it in BungeeCord because if I do, then people will want snapshots too, and then this, and then that, and then it becomes a NIGHTMARE to support.
    Besides with the new launcher changing is a click away.
     
    • Informative x 3
    • Agree x 2
    • Like x 1
    • Funny x 1
    • Winner x 1
  5. TitanicFreak

    Patron

    I give ya credit on that. However it can't be that hard for only real releases that don't have many differences between em can't it?
     
  6. prplz

    Supporter

    He develops this stuff in his spare time free of charge, if he doesn't want to do it then let him be.
     
    • Like Like x 1
  7. md_5

    Administrator Developer

    Yeah, its easy for now, literally a few lines of code.
    But if I do it now, then people will demand 1.7 support, then 1.8 support, etc etc, this will eventually lead to the bungee codebase being extremely polluted with versions.
     
    • Agree Agree x 2
  8. TitanicFreak

    Patron

    Can't argue with that, anyway its easy to change versions so i ain't complaining.
     
  9. Should make it only allow a few versions below (Say one or 2) would make it a bit less confusing for users, or have an option for users to turn it on/off in config.

    Just be strict and restrict it to Bungee/spigot only having 3 versions accessible... The latest and the two below
     

  10. Or just the minor version updates. Example 1.6.0, 1.6.1, 1.6.2, 1.6.3 then once 1.7 comes out have just 1.7 and any of their 1.7.x minor updates. Although with the new launcher and being able to change versions on the fly I can see why md_5 might see it as pointless.
     
  11. md_5

    Administrator Developer

    To be honest, 1.6.x has been the first time ever in which Minecraft has released an update the could of been backwards compatible, but wasn't. It is certainly doable now, but then I wouldn't hold your breath on 1.7.0 and 1.7.1 being compatible, as packets would probably be changed.

    Bungee can support multiple versions at once when packets are not changed, but when they are, it gets too difficult as then you need to have different versions for each server and client etc etc. So my reasoning behind not including these 6 lines of code is:
    • Users can select any version via the launcher
    • If I do it now, people will expect it for allowing 1.6 and 1.7 together, which is not as easily possible, or worth it from a technical standpoint, as you would now need to have your network part 1.6 servers and part 1.7 servers.
     
  12. Puremin0rez

    Moderator


    Refreshing the server list with that patch on a version that isn't 1.6.4 often shows that its incompatible, basically random chance with the refresh button. Similar to when Netty was first added in Spigot :p
     
  13. md_5

    Administrator Developer

    Just to add to this, in 1.7 the auth servers changed. Meaning if I want to do 1.6 and 1.7 I would have to write 2 sets of auth code, stuff like that gets very messy very fast.
     
  14. I'd love the idea of supporting minor versions 1.6.x and then when 1.7 comes around only supporting this. Few reasons for this: Some servers I play haven't updated and when I go on my server I have to exit the loader and change version.

    You could just specifically say you will only support minor releases in this so people cannot harass you for more.
     
  15. md_5

    Administrator Developer

    So, I was about to do this. Then I realised another issue, should the backend servers be 1.6.2 or 1.6.4 - you can only support one or the other. There are simply so many unknowns :(
     
  16. Scrayos

    Supporter

    The Backend-Servers should always be on the latest version, due the bug-fixes that were made.
     
    • Agree Agree x 1
  17. md_5

    Administrator Developer

    But then users complain their plugins dont work and they want 1.6.4 clients to connect to 1.6.2 servers, as opposed to vice versa.
     
  18. md_5 is there a tut about how to edit the spigot Src on github? I keep failing on trying to get it working.
     
  19. md_5

    Administrator Developer

    Its not easy to do this on Spigot. Much easier on Bungee.
     
Thread Status:
Not open for further replies.