How TO Convert 1.16 Worlds to 1.12.2

Discussion in 'Spigot Help' started by PmzHeroV2, Jun 29, 2021.

  1. We Runned our lobby server in 1.16.5 but now for ram issues we want to downgrade the lobby server. the world is in 1.16.5. i want to use the world
     
    • Funny Funny x 1
  2. As far as I know it is impossible to safely downgrade a world.
    You could however save the lobby in a schematic using worldedit and load it back in on the 1.12.2 world (Provided there are no 1.12.2+ blocks in the build)
     
    • Agree Agree x 2
  3. Unfortunately it won't be possible, too many blocks will cause conflicts that will corrupt the map, once you change the above version, it will be impossible to go back.

    Regards,
    Eng. Caio Vinicius.
     
  4. A 1.16.5 server load is not so bad when considering the requirements for 1.17+
    If you want the features of later builds, you have to accept the consequences.
    Reverting to an older server version is difficult and is very prone to errors.
    If you have an old version backup which you could revert to, that could be easier.

    My best suggestion would be to upgrade your server to cope with the newer version.