How to make pvp 1.7.10

Discussion in 'Spigot Help' started by Phill, Apr 16, 2017.

  1. Hello I own a 1.8.9 server and some people were having questions how to make my server have 1.7 pvp and still be 1.8 is it possible even ? Or does your server have to be 1.7.10?
     
  2. Do you mean that they can enter with both versions?
     
  3. Get spigot 1.8.8, use protocol support plugin to be able to have players join on 1.7.
     
  4. I want my server to have 1.7.10 pvp and my server be 1.8
     
  5. Hmm in the overview is the: "Mods 1.10. *, 1.9. *, 1.8. *, 1.7. *, 1.6. *, 1.5. *, 1.4.7 clients support to your spigot 1.11.2 server"

    EDIT::
    Oh, then i cant help you sorry :(
     
  6. Build #1649 is 1.7 and 1.8 compatible.
     
  7. I believe it's 1.7 allowing 1.8 users, not 1.8 allowing 1.7 users.
     
  8. latiku

    Supporter

    I'm pretty sure he wants to revert 1.7 PvP mechanics while having his server remain 1.8.

    In this case, I don't think a plugin exists for it yet and instead of paying hundreds of dollars for a developer to make one you can downgrade your server to 1.7 and use the protocol hack to remain 1.8 compatability.
     
  9. No there is a plugin that exists, it's called Protocol Support. You can have a 1.8.8 server and by using Protocol Support plugin it downgrades it to 1.7 so 1.7 and 1.8 clients can join. I use this on my network along with ViaVersion to have players join from 1.7.x to 1.11.x without any compatibility issues.
     
  10. You cant join with 1.7.* in ViaVersion.
     
    • Optimistic Optimistic x 1
  11. latiku

    Supporter

    That doesn't do what he wants. He's asking for old PvP mechanics to be reverted, not for 1.7 clients being allowed to join
     
  12. Yes that's why you use ProtocolSupport to have clients from 1.7.* - 1.11.* join.

    I thought OP wanted his server to be in 1.8, but allow players to join in 1.7. But if he wants old PvP mechanics, why not just have players join in 1.7? 90% of competitive PvPers use 1.7.10 already.
     
  13. Phill,

    There is a plugin that allows PvP to be changed based off the version, which is called OldCombatMechanicals.