How to make your server jar support multiple versions

Discussion in 'Programming' started by iUseRod, Aug 26, 2021.

  1. I never said it was impossible. I told you how it would work and ways to do it. BuildTools allows you to decompile a Minecraft version so all you would need to do is move the Packet Classes and their dependencies.
     
  2. The reason I didn't suggest that is because they haven't given permission for him to decompile the JAR. Suggesting that can create very dangerous habits or "gotos".
     
    • Optimistic Optimistic x 1
  3. Via Version and if you want even more versions use ViaRewind with viaversion
     
  4. The 1.7.10 spigot with support for 1.8.8 exists because md_5 and others have done mentionable amounts of work editing the server to support both 1.7.10 and 1.8.8 protocol by carefully examining each packets differences.

    If you get hired to do something, you should know how and what to do beforehand.
    you should give up that money and simply tell the one that hired you to use
    ViaVersion, ViaBackwards and ViaRewind
    for free 1.7.10 support on 1.8.8 server
     
    • Like Like x 1
    • Agree Agree x 1
  5. Strahan

    Benefactor

    I generally agree with that, but there are times when it's acceptable. As long as your client knows you are going into it blind and they are willing to pay you to figure something out, that's cool. There are times a client trusts your skills and would rather pay you to work on something than hire someone they don't know. Happened a few times with me in the past; I was once hired to work on a Banyan Vines network. I knew absolutely f' all about BV, lol, but they wanted me bad enough to pay me to drive to Pittsburgh (~230 miles) with the understanding time and materials are due regardless of project completion.
     
  6. Agree with this so much. You/the client is inventing an XY problem. There are literally free plugins (ViaRewind) that allow 1.7.10 clients to connect to a 1.8.8 server, which is orders of magnitude simpler than this broken idea of integrating it into the core manually.
     
  7. wtf? i'm not hired to specifically do the 1.7.10 & 1.8.8 support especially, this was one of the features he asked... lol?
     
    • Funny Funny x 1
  8. Well in that case I would be honest with the client and tell him/her that this specific request isn't a good solution and can be solved better using free plugins. And you can still work on the other requests. I can't think of a single client who wouldn't understand/be happier with that scenario ultimately.
     
    • Like Like x 1
  9. Strahan

    Benefactor

    Why do you sound so defensive about this? Nobody is attacking you, people are just pointing out why it's a terrible idea.
     
    • Agree Agree x 2
  10. (y)