Spigot [HowToMinecraft:S4] Unlock Ores 1.8

Allow players to unlock the ability to mine different ores!

  1. Funtime submitted a new resource:

    Unlock Ores - Allow players to unlock the ability to mine different ores!

    Read more about this resource...
     
  2. Thanks for downloading my Skript! :D If you feel that you have any good suggestion you'd like to see in the next update or if you have an issue, be sure to comment down below! Also, if you have any idea for a new Skript...I'd also love to hear them!
     
  3. How do I intall this on to my server its not a jar ??

    Pls tell me .
     
  4. It is a Skript file, completly different to jar. If you wish to download it you need the plugins: "Skript" and "SkQuery", and then place this file in your "scripts" folder. After you've done that, restart your server or do /sk reload UnlockOre.
     
  5. Could you provide the download links for the plugins needed to run the plugin
     
  6. Done! :)
     
  7. Thank you sir. :)
     
  8. Um, how do you change the plugin to use PermissionsEX? Gonna begin configuring tomorrow for my server
     
  9. Replace "manuaddp %player% {orePerm}" to "pex user %player% add {orePerm}"

    There is a possibility I'll work on an update so you can easily change it :)
    EDIT: Done!
     
    #12 Funtime, May 30, 2017
    Last edited: May 30, 2017
  10. thx

    I did now what u said , i started my server and looked in the consol and saw that it was full of errors from the plugin skript so I sadly cant use your ' plugin '
     
  11. Can you paste in the error?
     
  12. This is the erro without your skript in it :






    [19:35:01 INFO]: [Skript] An internal error occurred while checking for the latest version of Skript. Please refer to the server log for details.
    [19:35:01 ERROR]: #!#!
    [19:35:01 ERROR]: #!#! [Skript] Severe Error:
    [19:35:01 ERROR]: #!#! Unexpected error while checking for a new version of Skript
    [19:35:01 ERROR]: #!#!
    [19:35:01 ERROR]: #!#! If you're developing an add-on for Skript this likely means that you have done something wrong.
    [19:35:01 ERROR]: #!#! If you're a server admin however please go to http://dev.bukkit.org/server-mods/skript/tickets/
    [19:35:01 ERROR]: #!#! and check whether this error has already been reported.
    [19:35:01 ERROR]: #!#! If not please create a new ticket with a meaningful title, copy & paste this whole error into it,
    [19:35:01 ERROR]: #!#! and describe what you did before it happened and/or what you think caused the error.
    [19:35:01 ERROR]: #!#! If you think that it's a trigger that's causing the error please post the trigger as well.
    [19:35:01 ERROR]: #!#! By following this guide fixing the error should be easy and done fast.
    [19:35:01 ERROR]: #!#!
    [19:35:01 ERROR]: #!#! Stack trace:
    [19:35:01 ERROR]: #!#! javax.xml.stream.XMLStreamException: ParseError at [row,col]:[1,1]
    Message: Premature end of file.
    [19:35:01 ERROR]: #!#! at com.sun.org.apache.xerces.internal.impl.XMLStreamReaderImpl.next(XMLStreamReaderImpl.java:604)
    [19:35:01 ERROR]: #!#! at com.sun.xml.internal.stream.XMLEventReaderImpl.nextEvent(XMLEventReaderImpl.java:83)
    [19:35:01 ERROR]: #!#! at ch.njol.skript.Updater.getChangelogs(Updater.java:286)
    [19:35:01 ERROR]: #!#! at ch.njol.skript.Updater$2.run(Updater.java:210)
    [19:35:01 ERROR]: #!#! at java.lang.Thread.run(Thread.java:748)
    [19:35:01 ERROR]: #!#!
    [19:35:01 ERROR]: #!#! Version Information:
    [19:35:01 ERROR]: #!#! Skript: 2.1.2
    [19:35:01 ERROR]: #!#! Bukkit: 1.8.8-R0.1-SNAPSHOT
    [19:35:01 ERROR]: #!#! Minecraft: 1.8.8
    [19:35:01 ERROR]: #!#! Java: 1.8.0_131
    [19:35:01 ERROR]: #!#!
    [19:35:01 ERROR]: #!#! Running CraftBukkit: false
    [19:35:01 ERROR]: #!#!
    [19:35:01 ERROR]: #!#! Current node: databases: (config.sk, line 141)
    [19:35:01 ERROR]: #!#! Current item: null
    [19:35:01 ERROR]: #!#!
    [19:35:01 ERROR]: #!#! Thread: Skript update thread
    [19:35:01 ERROR]: #!#!
    [19:35:01 ERROR]: #!#! End of Error.
    [19:35:01 ERROR]: #!#!
    [19:35:01 INFO]: [Skript] You're currently running the latest stable version of Skript.
     
  13. Its not really an error, it just cant look up the latest version of skript
     
  14. So why does it not work for me ??
     
  15. Try to use benskus fork of Skript, ive had no issues with it
     
  16. Is this Skript compatible with 1.11?, if it isn't could you make it compatible?