Hum can you help me?

Discussion in 'BungeeCord Help' started by ClearRelic24, Feb 1, 2020.

  1. Want i start the bungeecord, i have this error message:
    [email protected]:/home/BC# ./start.sh
    21:00:17 [INFO] Using mbed TLS based native cipher.
    21:00:17 [INFO] Using zlib based native compressor.
    21:00:17 [INFO] Enabled BungeeCord version git:BungeeCord-Bootstrap:1.15-SNAPSHOT:a3ab2bf:1473
    21:00:18 [INFO] Not on Windows, attempting to use enhanced EpollEventLoop
    21:00:18 [INFO] Epoll is working, utilising it!
    21:00:18 [INFO] Discovered module: ModuleSpec(name=cmd_alert, file=modules/cmd_alert.jar, provider=JenkinsModuleSource())
    21:00:18 [INFO] Discovered module: ModuleSpec(name=cmd_find, file=modules/cmd_find.jar, provider=JenkinsModuleSource())
    21:00:18 [INFO] Discovered module: ModuleSpec(name=cmd_list, file=modules/cmd_list.jar, provider=JenkinsModuleSource())
    21:00:18 [INFO] Discovered module: ModuleSpec(name=cmd_send, file=modules/cmd_send.jar, provider=JenkinsModuleSource())
    21:00:18 [INFO] Discovered module: ModuleSpec(name=cmd_server, file=modules/cmd_server.jar, provider=JenkinsModuleSource())
    21:00:18 [INFO] Discovered module: ModuleSpec(name=reconnect_yaml, file=modules/reconnect_yaml.jar, provider=JenkinsModuleSource())
    21:00:18 [INFO] Attempting to update plugin from ModuleVersion(build=1471, git=7bd8a02) to ModuleVersion(build=1473, git=a3ab2bf)
    21:00:18 [INFO] Attempting to Jenkins download module cmd_alert v1473
    21:00:19 [INFO] Download complete
    21:00:19 [INFO] Attempting to update plugin from ModuleVersion(build=1471, git=7bd8a02) to ModuleVersion(build=1473, git=a3ab2bf)
    21:00:19 [INFO] Attempting to Jenkins download module cmd_find v1473
    21:00:19 [INFO] Download complete
    21:00:19 [INFO] Attempting to update plugin from ModuleVersion(build=1471, git=7bd8a02) to ModuleVersion(build=1473, git=a3ab2bf)
    21:00:19 [INFO] Attempting to Jenkins download module cmd_list v1473
    21:00:19 [INFO] Download complete
    21:00:19 [INFO] Attempting to update plugin from ModuleVersion(build=1471, git=7bd8a02) to ModuleVersion(build=1473, git=a3ab2bf)
    21:00:19 [INFO] Attempting to Jenkins download module cmd_send v1473
    21:00:19 [INFO] Download complete
    21:00:19 [INFO] Attempting to update plugin from ModuleVersion(build=1471, git=7bd8a02) to ModuleVersion(build=1473, git=a3ab2bf)
    21:00:19 [INFO] Attempting to Jenkins download module cmd_server v1473
    21:00:19 [INFO] Download complete
    21:00:19 [INFO] Attempting to update plugin from ModuleVersion(build=1471, git=7bd8a02) to ModuleVersion(build=1473, git=a3ab2bf)
    21:00:19 [INFO] Attempting to Jenkins download module reconnect_yaml v1473
    21:00:19 [INFO] Download complete
    21:00:19 [INFO] Loaded plugin reconnect_yaml version git:reconnect_yaml:1.15-SNAPSHOT:a3ab2bf:1473 by SpigotMC
    21:00:19 [INFO] Loaded plugin cmd_find version git:cmd_find:1.15-SNAPSHOT:a3ab2bf:1473 by SpigotMC
    21:00:19 [INFO] Loaded plugin cmd_server version git:cmd_server:1.15-SNAPSHOT:a3ab2bf:1473 by SpigotMC
    21:00:19 [INFO] Loaded plugin cmd_alert version git:cmd_alert:1.15-SNAPSHOT:a3ab2bf:1473 by SpigotMC
    21:00:19 [INFO] Loaded plugin cmd_send version git:cmd_send:1.15-SNAPSHOT:a3ab2bf:1473 by SpigotMC
    21:00:19 [INFO] Loaded plugin cmd_list version git:cmd_list:1.15-SNAPSHOT:a3ab2bf:1473 by SpigotMC
    21:00:19 [SEVERE] Exception in thread "main"
    21:00:19 [SEVERE] java.lang.ClassCastException: java.lang.Integer cannot be cast to java.lang.String
    21:00:19 [SEVERE] at net.md_5.bungee.conf.YamlConfig.getServers(YamlConfig.java:214)
    21:00:19 [SEVERE] at net.md_5.bungee.conf.Configuration.load(Configuration.java:106)
    21:00:19 [SEVERE] at net.md_5.bungee.BungeeCord.start(BungeeCord.java:267)
    21:00:19 [SEVERE] at net.md_5.bungee.BungeeCordLauncher.main(BungeeCordLauncher.java:62)
    21:00:19 [SEVERE] at net.md_5.bungee.Bootstrap.main(Bootstrap.java:15)


    How to resolve this?
     
  2. Phoenix616

    Resource Staff

    You have an error in Bungee's config.yml, some value is set to an integer that should be a string. Make sure all options that should be strings are surrounded by ' or " (or post your config and let someone take a look)