I can’t join my Bungeecord proxy

Discussion in 'BungeeCord Discussion' started by freezeline, Jul 2, 2021.

  1. Hello! I got 4 servers running, one of them is proxy, I followed tutorials and finished the setup, but when I tried to join the server with the ip adress from the proxy server, I got an error "Connection refused: no further information". I don't know why this is happening, can you help me solve this?


    I also get a lot of: "(0):" in the console


    Here is Bungeecords config: https://pastebin.com/9fqyKsiQ


    And here is the config for the other servers (spigot.ylm): https://pastebin.com/RJLAfarE

    And here is the server properties for the other servers: https://pastebin.com/1tHLGEP0


    I marked my ip as "*"
     
  2. The client cannot reach the bungeecord server, is it firewalled? Are you connecting to right IP and port? Are you using right version?
     
  3. Do I need to have bungeecord the same version as the lobby?
     
  4. I think the port is closed
     
  5. Where are your servers hosted (on a server or home-hosted)?
     
  6. They are hosted on Shockbyte, but it takes ages (About 2 days) for their support to answer a simple question
     
  7. Oh! Then the port of your bungeecord server must be open correctly. Make sure that the port and IP you are using are the ones that appear on your panel.

    Also! Since you are on shared hosting, you probably also want to contact them so they can help you set up your network correctly. (Your Spigot servers must be firewalled correctly, they mustn't be open to the internet)
     
  8. All servers are configured correctly, I think. Everytime I start them, it says "server configured for bungeecord" also I have bungeecord enabled in all config files as well as I have online mode on false. The only server with online mode on true in the proxy server
     
  9. Also my proxy's console is getting spammed with: [Server] INFO (0):
     
  10. Yes, but I highly doubt you have the port 25577 allocated (this is the port you are using on your Bungeecord server). If I remember correctly, Shockbyte uses Multicraft, meaning that you should be able to see which port you have allocated somewhere in the panel.
     
  11. Yes, here it is: 25567
     
  12. OMG I'M IN THANK YOU!
     
  13. Crap , I still have a problem:

    02.07 16:47:46 [Server] Startup Listening on /0.0.0.0:25577
    02.07 16:48:37 [Server] INFO (1): Freeze_Line
    02.07 16:48:37 [Server] INFO (0):
    02.07 16:48:37 [Server] INFO (0):
     
  14. It goes on and on
     
  15. Does the INFO (0) appear on your latest.log?
     
  16. Yes, it appears on the proxy's console right now.

    02.07 16:47:46 [Server] Startup Listening on /0.0.0.0:25577
    02.07 16:48:37 [Server] INFO (1): Freeze_Line
    02.07 16:48:37 [Server] INFO (0):
    02.07 16:48:37 [Server] INFO (0):
    02.07 16:49:27 [Server] INFO (1): Freeze_Line
    02.07 16:49:27 [Server] INFO (0):
    02.07 16:49:27 [Server] INFO (0):
    02.07 16:50:17 [Server] INFO (1): Freeze_Line
    02.07 16:50:17 [Server] INFO (0):
    02.07 16:50:17 [Server] INFO (0):
    02.07 16:51:07 [Server] INFO (1): Freeze_Line
    02.07 16:51:07 [Server] INFO (0):
    02.07 16:51:07 [Server] INFO (0):
    02.07 16:51:58 [Server] INFO (0):
    02.07 16:51:58 [Server] INFO (1): Freeze_Line
    02.07 16:51:58 [Server] INFO (0):
    02.07 16:52:48 [Server] INFO (1): Freeze_Line
    02.07 16:52:48 [Server] INFO (0):
    02.07 16:52:48 [Server] INFO (0):

    It became even bigger
     
  17. Go into your logs folder, then into the latest.log file and see if they appear there. If they don't appear on that file, then it is probably your panel that is having some issues.
     
  18. All I've found in log was:


    16:57:50 [INFO] §a[BedWars] §e(0): §r
    16:57:50 [INFO] §a[KitPVP] §e(0): §r
    16:57:50 [INFO] Total players online: 1

    So if it's an issue in my panel, should I just forget about it?
     
  19. You should contact your host about it.
     
  20. Okay, thank you so much!

    Have a nice day!