Solved If you wish to use IP forwarding, please enable it in your BungeeCord config as well!

Discussion in 'Spigot Help' started by LameDabe, Jul 9, 2018.

Thread Status:
Not open for further replies.
  1. Hi, the title is pretty straight forward, when I connect to my server it says "If you wish to use IP forwarding, please enable it in your BungeeCord config as well!". This has probably been asked a lot but I can't seem to fix it.
    Any help would be highly appreciated.
     
  2. https://www.spigotmc.org/wiki/bungeecord/

    Specifically....
    Code (Text):
    player_limit: -1
    ip_forward: false
    permissions:
      default:
      - bungeecord.command.server
      - bungeecord.command.list
      admin:
      - bungeecord.command.alert
      - bungeecord.command.end
      - bungeecord.command.ip
      - bungeecord.command.reload
     
  3. Go to the config.yml of the Bungeecord server and then set to "false" the setting "ip_forward" and then go to the spigot server, go to the spigot.yml and set the "bungeecord" setting to "true", that should fix your problem :)
     
  4. that didn't work. I did it twice, still no
     
  5. I did all the 3 steps it told me to do but at the part "If you see the error If you wish to use IP forwarding, please enable it in your BungeeCord config as well!, this would suggest you are connecting directly to the Spigot server instead of the BungeeCord server. You should always connect to your BungeeCord server IP." I quite didn't understand that so if you could be nice and explain what that means? If by connecting to the BungeeCord server IP you mean this:
    upload_2018-7-10_10-17-8.png
    then once I connected it said "Not authenticated with Minecraft.net". And yes, I don't have Minecraft purchased so I probably need to enable cracked clients to be able to join...but how do I do that?
     
    • Optimistic Optimistic x 1
  6. I went on the website and it was quite useful so thank you for that but once I added BungeeCord (I think you meant to tell me to get BungeeCord on my server..?) I downloaded it I went on how to set it up but it still didn't work. Afterwards I saw this tutorial and did a backup of my saved world on the previous server and as I said I did the whole thing But it's still popping up with the same error but as you can see above on my previous reply you can see that by typing my_local_IP:25565 it brings up that, but as I said, with the "Not authenticated with Minecraft.net", but if I do my_local_IP:25570 (25570 is the port to my BungeeCord lobby and that the one that the video states that I should connect to my spigot server) I get the same error "If you wish to use IP forwarding, please enable it in your BungeeCord config as well!"
     
  7. Sry, can't test your Bungee setup cause I don't use it. If there is a flaw in @md_5 Wiki please report it to him.

    I really doubt he will support a cracked client issue.
     
  8. Alright so apparently I had to connect to my BungeeCord IP rather than the Spigot one, ad for those who harha cracjed client just set online-mode to false in the BungeeCord config. And sorry for the late reply I had to do further testing to see if it's all good, and it is! Thanks for everyone helping me!
     
Thread Status:
Not open for further replies.