Incorrect permission node?

Discussion in 'Spigot Plugin Help' started by WanderEDG, Apr 24, 2017.

  1. So i have a SkyBlock server, and i want people to do /msg. So i gave them (and myself) the permission node:
    essentials.msg

    That does not work.
    Also essentials.msg.* or essentials.msg* does'nt work.
    I hope you can help me. Here is are my player permissions:
    groups:
    default:
    options:
    default: true
    permissions:
    - modifyworld.*
    - askyblock.island.*
    - askyblock.team.create
    - askyblock.team.kick
    - askyblock.team.makeleader
    - askyblock.team.join
    - askyblock.intopten
    - hubthat.nohubdelay
    - essentials.warp
    - hubthat.hub
    - simpleprefix.default
    - essentials.signs.use.buy
    - essentials.balance
    - chatformat.default
    - essentials.warp.list
    - essentials.signs.use.sell
    - essentials.pay
    - essentials.msg
    - essentials.tpa
    - essentials.tpahere
    - essentials.tpaccept
    - essentials.tpdeny
    - askyblock.craft.enderchest
    - essentials.balancetop
    - essentials.silentjoin
    - essentials.silentquit
    - nte.default
     
  2. Have you tried reloading or restarting?
     
  3. Gaxan

    Supporter

    #3 Gaxan, Apr 24, 2017
    Last edited: Apr 24, 2017
    • Like Like x 1
    • Agree Agree x 1
  4. BrettplayMC: Yes, i did.
    Gaxan: i did not know it was a seperate plugin, and i use PEX for permissions. i succesfully installed EssentialsChat, but still, it does not work.
     
  5. Essentials or EssentialsX? Make sure you are using either or.
     
  6. Gaxan

    Supporter

    Which version of essentials and spigot are you using? Make sure to enable the essentials chat permissions as well.
     
  7. EssentialsX: 2.0.1
    Spigot: Latest 1.11.2 build
     
  8. Try adding Permission Node: essentials.message ? That may make it work!

    EDIT:
    Oh, Maybe essential.chat.message or essentialchat.message ? or switch the message to msg !
     
  9. Tried, does not work.
     
  10. Latest build from Jenkins?
     
  11. Let me check my sources...
     
  12. Gaxan

    Supporter

    Here are the permissions you need to use. Exclude any you do not want available to players.
    essentials.msg
    essentials.msg.color
    essentials.msg.format
    essentials.msg.magic
    essentials.msg.multiple
    essentials.msg.url
    essentials.chat.color
    essentials.chat.format
    essentials.chat.magic
    essentials.chat.question
    essentials.chat.shout
    essentials.chat.url

    Also, post your essentials config. use a paste bin or [ code ] [ /code ] without the spacing.
     
    #13 Gaxan, Apr 24, 2017
    Last edited: Apr 24, 2017
    • Like Like x 1