Premium Industrial-MC [CUSTOM BLOCKS] [INDUSTRIAL CRAFT LIKE] [UNIQUE] [1.11.x-1.12.x] [25% OFF FOR...

Discussion in 'Resource Discussion' started by BlockMcGee, Mar 19, 2017.

  1. well i'll add you as you and mini digger seem very honorable members, have fun!
     
  2. can you send me the latest log after the update?
     
  3. i also recommend to watch the toturial video, read some update logs and read the FAQ so there won't be any confusion
     
  4. @BlockMcGee

    [15:45:45] [Server thread/INFO]: [Industrial-MC] Enabling Industrial-MC v1.9.5
    [15:45:46] [Thread-14/INFO]: [ClearLag] No updates found!
    [15:45:46] [Server thread/INFO]: -----IndustrialMC v1.9.5-----
    [15:45:46] [Server thread/INFO]: 4 Machines Registered.
    [15:45:46] [Server thread/INFO]: Added Crafting Recipes.
    [15:45:46] [Server thread/INFO]: WorldGuard plugin found!
    [15:45:46] [Server thread/INFO]: GriefPrevention not found.
    [15:45:46] [Server thread/INFO]: Machines Have Been Refreshed.
    [15:45:46] [Server thread/INFO]: -----Version Date: 19/12/2017-----
    [19:49:25] [Server thread/ERROR]: Could not pass event PlayerInteractAtEntityEvent to Industrial-MC v1.9.5
    org.bukkit.event.EventException: null
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:306) ~[spigotlatest.jar:git-Spigot-549c1fa-70cc382]
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62) ~[spigotlatest.jar:git-Spigot-549c1fa-70cc382]
    at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:500) [spigotlatest.jar:git-Spigot-549c1fa-70cc382]
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:485) [spigotlatest.jar:git-Spigot-549c1fa-70cc382]
    at net.minecraft.server.v1_12_R1.PlayerConnection.a(PlayerConnection.java:1580) [spigotlatest.jar:git-Spigot-549c1fa-70cc382]
    at net.minecraft.server.v1_12_R1.PacketPlayInUseEntity.a(SourceFile:69) [spigotlatest.jar:git-Spigot-549c1fa-70cc382]
    at net.minecraft.server.v1_12_R1.PacketPlayInUseEntity.a(SourceFile:13) [spigotlatest.jar:git-Spigot-549c1fa-70cc382]
    at net.minecraft.server.v1_12_R1.PlayerConnectionUtils$1.run(SourceFile:13) [spigotlatest.jar:git-Spigot-549c1fa-70cc382]
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_121]
    at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_121]
    at net.minecraft.server.v1_12_R1.SystemUtils.a(SourceFile:46) [spigotlatest.jar:git-Spigot-549c1fa-70cc382]
    at net.minecraft.server.v1_12_R1.MinecraftServer.D(MinecraftServer.java:748) [spigotlatest.jar:git-Spigot-549c1fa-70cc382]
    at net.minecraft.server.v1_12_R1.DedicatedServer.D(DedicatedServer.java:406) [spigotlatest.jar:git-Spigot-549c1fa-70cc382]
    at net.minecraft.server.v1_12_R1.MinecraftServer.C(MinecraftServer.java:679) [spigotlatest.jar:git-Spigot-549c1fa-70cc382]
    at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:577) [spigotlatest.jar:git-Spigot-549c1fa-70cc382]
    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_121]
    Caused by: java.lang.NullPointerException
    at pack.plug.EventListenmate.playerUsedSafariNet(EventListenmate.java:2615) ~[?:?]
    at sun.reflect.GeneratedMethodAccessor574.invoke(Unknown Source) ~[?:?]
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[?:1.8.0_121]
    at java.lang.reflect.Method.invoke(Method.java:498) ~[?:1.8.0_121]
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:302) ~[spigotlatest.jar:git-Spigot-549c1fa-70cc382]
    ... 15 more
    [19:49:51] [Server thread/INFO]: =====
    [19:49:51] [Server thread/INFO]: Hey! Join our Discord now: https://discord.gg/W8chXpq
    [19:49:51] [Server thread/INFO]: =====

    These are the ones u need I hope. Please solve my issue quickly!
     
  5. if this update still doesnt fix it, then send me a new log...
     
  6. 26.12 04:05:49 [Server] INFO [Industrial-MC] Enabling Industrial-MC v1.9.5-C 26.12 04:05:49 [Server] INFO [ClearLag] No updates found! 26.12 04:05:49 [Server] INFO -----IndustrialMC v1.9.5-C----- 26.12 04:05:49 [Server] INFO 4 Machines Registered. 26.12 04:05:49 [Server] INFO Added Crafting Recipes. 26.12 04:05:49 [Server] INFO WorldGuard plugin found! 26.12 04:05:49 [Server] INFO GriefPrevention not found. 26.12 04:05:49 [Server] INFO Machines Have Been Refreshed. 26.12 04:05:49 [Server] INFO -----Version Date: 19/12/2017-----

    26.12 04:06:34 [Server] INFO Tried to load unrecognized recipe: bukkit:69473edf-9dad-400e-91e5-1c5bc5e48bec removed now. 26.12 04:06:34 [Server] INFO Tried to load unrecognized recipe: bukkit:69473edf-9dad-400e-91e5-1c5bc5e48bec removed now.

    I have also restarted a bunch of times, I dont get erros as such but custom blocks still dont show up

    [​IMG]

    @BlockMcGee sorry but could you please try to resolve the issue?
     
  7. i'm trying to resolve it... try running the reloadcustomblocks command, wait for it to stop the server, then when it starts up again, restart it one more time after it says "industrial mc has successfully loaded"
     
  8. Yes it worked thanks, Btw could we get some more details about coal liquifactor?
     
  9. right click it with an empty hand, place coal blocks in the allocated slot, close it, right click with a wrench, turn it on with the emerald, then right click it with an empty bottle to get the oil, read update note for version 1.9.5 for more info.
     
  10. People get 'insufficient permission' error using safari net, and i cant see any permission node for that @BlockMcGee
     
  11. its industrial.machine.safarinet, i guess i forgot that.. thanks for the report ill update the permission list..
     
  12. @BlockMcGee i would really like to use this plugin. i bought it but i dont want to use custom textures. Not all players want to use server textures and without them most blocks (spawners) look bad.

    - Could you add an option to use player skull textures instead? this would be so cool!

    - And could you imagine to make auto crafters and harvesters have a output chest so that i can use it together with TransportPipes?
     
  13. using player skulls as textures is possible but getting the required skins would be a hassle. i guess i can make harvesters and autocrafters compatible with hoppers as making them output to chests would be pretty difficult because of legacy support..
     
  14. no i mean just an option to use skulls with skins of choice.
    hoppers are good enough :)