Spigot Infinity and Mending Unnerf Version 1.2.2

A very simple plugin that allows infinity and mending to be together once again!

  1. WolfLeader116 submitted a new resource:

    Infinity and Mending Unnerf - A very simple plugin that allows infinity and mending to be together once again!

    Read more about this resource...
     
  2. It works great!
    But I have another question:
    Does this plugin exist for swords and Armour too? (Sharpness + Smite; Depht Strider + Frost Walker...)
     
  3. how do i make my server use jave 9? please help i cannot find anyone who will tell me
     
  4. install java 9 on your computer

    Please update this to 1.16.1 as it will not work
    Code (Text):
    [12:56:23] [Server thread/INFO]: Initialized attach.dll!
    [12:56:23] [Server thread/WARN]: java.util.ServiceConfigurationError: com.sun.tools.attach.spi.AttachProvider: Provider sun.tools.attach.WindowsAttachProvider could not be instantiated
    [12:56:23] [Server thread/ERROR]: Error occurred while enabling InfinityMendingUnnerf v1.1 (Is it up to date?)
    java.lang.IllegalStateException: Error during attachment using: [email protected]6d31182
            at net.bytebuddy.agent.ByteBuddyAgent.install(ByteBuddyAgent.java:608) ~[?:?]
            at net.bytebuddy.agent.ByteBuddyAgent.install(ByteBuddyAgent.java:581) ~[?:?]
            at net.bytebuddy.agent.ByteBuddyAgent.install(ByteBuddyAgent.java:533) ~[?:?]
            at net.bytebuddy.agent.ByteBuddyAgent.install(ByteBuddyAgent.java:510) ~[?:?]
            at io.github.pseudoresonance.infinitymendingunnerf.Unnerf.onEnable(Unnerf.java:73) ~[?:?]
            at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:263) ~[spigot-1.16.1.jar:git-Spigot-16d7899-4ff609e]
            at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:351) ~[spigot-1.16.1.jar:git-Spigot-16d7899-4ff609e]
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:480) ~[spigot-1.16.1.jar:git-Spigot-16d7899-4ff609e]
            at org.bukkit.craftbukkit.v1_16_R1.CraftServer.enablePlugin(CraftServer.java:491) ~[spigot-1.16.1.jar:git-Spigot-16d7899-4ff609e]
            at org.bukkit.craftbukkit.v1_16_R1.CraftServer.enablePlugins(CraftServer.java:405) ~[spigot-1.16.1.jar:git-Spigot-16d7899-4ff609e]
            at org.bukkit.craftbukkit.v1_16_R1.CraftServer.reload(CraftServer.java:873) ~[spigot-1.16.1.jar:git-Spigot-16d7899-4ff609e]
            at org.bukkit.Bukkit.reload(Bukkit.java:642) ~[spigot-1.16.1.jar:git-Spigot-16d7899-4ff609e]
            at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:27) ~[spigot-1.16.1.jar:git-Spigot-16d7899-4ff609e]
            at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:149) ~[spigot-1.16.1.jar:git-Spigot-16d7899-4ff609e]
            at org.bukkit.craftbukkit.v1_16_R1.CraftServer.dispatchCommand(CraftServer.java:755) ~[spigot-1.16.1.jar:git-Spigot-16d7899-4ff609e]
            at org.bukkit.craftbukkit.v1_16_R1.CraftServer.dispatchServerCommand(CraftServer.java:740) ~[spigot-1.16.1.jar:git-Spigot-16d7899-4ff609e]
            at net.minecraft.server.v1_16_R1.DedicatedServer.handleCommandQueue(DedicatedServer.java:386) ~[spigot-1.16.1.jar:git-Spigot-16d7899-4ff609e]
            at net.minecraft.server.v1_16_R1.DedicatedServer.b(DedicatedServer.java:355) ~[spigot-1.16.1.jar:git-Spigot-16d7899-4ff609e]
            at net.minecraft.server.v1_16_R1.MinecraftServer.a(MinecraftServer.java:1009) ~[spigot-1.16.1.jar:git-Spigot-16d7899-4ff609e]
            at net.minecraft.server.v1_16_R1.MinecraftServer.v(MinecraftServer.java:848) ~[spigot-1.16.1.jar:git-Spigot-16d7899-4ff609e]
            at net.minecraft.server.v1_16_R1.MinecraftServer.lambda$0(MinecraftServer.java:164) ~[spigot-1.16.1.jar:git-Spigot-16d7899-4ff609e]
            at java.lang.Thread.run(Unknown Source) [?:1.8.0_202]
    Caused by: java.lang.reflect.InvocationTargetException
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_202]
            at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_202]
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_202]
            at java.lang.reflect.Method.invoke(Unknown Source) ~[?:1.8.0_202]
            at net.bytebuddy.agent.Attacher.install(Attacher.java:106) ~[?:?]
            at net.bytebuddy.agent.ByteBuddyAgent.install(ByteBuddyAgent.java:603) ~[?:?]
            ... 21 more
    Caused by: com.sun.tools.attach.AttachNotSupportedException: no providers installed
            at com.sun.tools.attach.VirtualMachine.attach(VirtualMachine.java:203) ~[?:?]
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0_202]
            at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_202]
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0_202]
            at java.lang.reflect.Method.invoke(Unknown Source) ~[?:1.8.0_202]
            at net.bytebuddy.agent.Attacher.install(Attacher.java:106) ~[?:?]
            at net.bytebuddy.agent.ByteBuddyAgent.install(ByteBuddyAgent.java:603) ~[?:?]
            ... 21 more
    I'm using Java 1.8 with the tools.jar and attach.dll copied from the 1.8 JDK to \plugins\InfinityMendingUnnerf
     
  5. Code (Java):
    05.07 16:18:20 [Server] INFO [InfinityMendingUnnerf] Enabling InfinityMendingUnnerf v1.2.1
    05.07 16:18:20 [Server] INFO Loading in Minecraft 1.16
    05.07 16:18:20 [Server] INFO Minecraft 1.11 or later.
    05.07 16:18:20 [Server] INFO Running Java 8 or older!
    05.07 16:18:20 [Server] INFO Running JDK! Proceeding...
    05.07 16:18:20 [Server] INFO Loading injector!
    05.07 16:18:21 [Server] INFO Injector loaded! Beginning injection of custom mending/infinity code!
    05.07 16:18:21 [Server] INFO Found necessary classes!
    05.07 16:18:21 [Server] INFO Injection complete! Infinity and mending are no longer exclusive!
    05.07 16:18:21 [Server] ERROR Error occurred while enabling InfinityMendingUnnerf v1.2.1 (Is it up to date?)
    05.07 16:18:21 [Server] INFO java.lang.ExceptionInInitializerError: null
    05.07 16:18:21 [Server] INFO at io.github.pseudoresonance.infinitymendingunnerf.Unnerf.initializeMetrics(Unnerf.java:96) ~[?:?]
    05.07 16:18:21 [Server] INFO at io.github.pseudoresonance.infinitymendingunnerf.Unnerf.onEnable(Unnerf.java:92) ~[?:?]
    05.07 16:18:21 [Server] INFO at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:263) ~[patched_1.16.1.jar:git-Purpur-634]
    05.07 16:18:21 [Server] INFO at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:380) ~[patched_1.16.1.jar:git-Purpur-634]
    05.07 16:18:21 [Server] INFO at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:483) ~[patched_1.16.1.jar:git-Purpur-634]
    05.07 16:18:21 [Server] INFO at org.bukkit.craftbukkit.v1_16_R1.CraftServer.enablePlugin(CraftServer.java:500) ~[patched_1.16.1.jar:git-Purpur-634]
    05.07 16:18:21 [Server] INFO at org.bukkit.craftbukkit.v1_16_R1.CraftServer.enablePlugins(CraftServer.java:414) ~[patched_1.16.1.jar:git-Purpur-634]
    05.07 16:18:21 [Server] INFO at net.minecraft.server.v1_16_R1.MinecraftServer.loadWorld(MinecraftServer.java:472) ~[patched_1.16.1.jar:git-Purpur-634]
    05.07 16:18:21 [Server] INFO at net.minecraft.server.v1_16_R1.DedicatedServer.init(DedicatedServer.java:251) ~[patched_1.16.1.jar:git-Purpur-634]
    05.07 16:18:21 [Server] INFO at net.minecraft.server.v1_16_R1.MinecraftServer.v(MinecraftServer.java:942) ~[patched_1.16.1.jar:git-Purpur-634]
    05.07 16:18:21 [Server] INFO at net.minecraft.server.v1_16_R1.MinecraftServer.lambda$a$0(MinecraftServer.java:178) ~[patched_1.16.1.jar:git-Purpur-634]
    05.07 16:18:21 [Server] INFO at java.lang.Thread.run(Thread.java:748) [?:1.8.0_144]
    05.07 16:18:21 [Server] INFO Caused by: java.lang.IllegalStateException: bStats Metrics class has not been relocated correctly!
    05.07 16:18:21 [Server] INFO at org.bstats.bukkit.Metrics.<clinit>(Metrics.java:42) ~[?:?]
     
  6. how to install java 9?
     
  7. it failed to intialise attach.dll/attach.so!
    waht do i do??
     
  8. You need to be using Java 8 JDK or Java 9 or later on your server. If you are hosting from your own computer, you can install the JDK from https://adoptopenjdk.net/ or using the package manager on your computer, in the case of Linux. If you are not hosting on your own machine, you will have to speak with your hosting provider about if there is anything they can do.