Initializing Legacy Material Support. Unless you have legacy plugins and/or data this is a bug!

Discussion in 'Spigot Help' started by Venemiz, Jan 30, 2020.

  1. Hello, new user and pretty new user to spigot as well. I keep having issues with server stutters and sometimes rubberbanding. I've tried lowering render distance, changing network compression threshold among other settings in server.properties, as well as tinkering with the spigot and bukkit yml's. Something I keep noticing is that I keep getting the following message: "Initializing Legacy Material Support. Unless you have legacy plugins and/or data this is a bug!" I don't have any plugins installed, so could this message be related to my lag issues? If so, how would I fix it? And if not, does anyone have any pointers/ideas for me to try?
     
  2. This isn't a lag related issue in any way. You should pay attention to that message actually
     
  3. md_5

    Administrator Developer

    That message can only appear once.
    When does it appear? Post a log
     
  4. From what I’ve seen, happens early startup. Statement is a bit confusing since legacy plugins has meant below 1.13 but in this case does it mean below 1.15?
     
  5. md_5

    Administrator Developer

    No it means below 1.13 and it will happen early startup if you have any installed
     
    • Like Like x 1
  6. Just for funsies I decided to test:

    I did a test with both NO PLUGINS and then another test with 1 plugin (api-version = 1.15)
    Code (Text):
    ShaneBees-MacBook-Pro:~ ShaneBee$ /Users/ShaneBee/Desktop/Server/LEGACY/START-SPIGOT.command ; exit;
    Loading libraries, please wait...
    [13:47:29] [Server thread/INFO]: Starting minecraft server version 1.15.2
    [13:47:29] [Server thread/INFO]: Loading properties
    [13:47:29] [Server thread/INFO]: This server is running CraftBukkit version git-Spigot-b9baf71-df371c1 (MC: 1.15.2) (Implementing API version 1.15.2-R0.1-SNAPSHOT)
    [13:47:29] [Server thread/INFO]: Debug logging is disabled
    [13:47:29] [Server thread/INFO]: Server Ping Player Sample Count: 12
    [13:47:29] [Server thread/INFO]: Using 4 threads for Netty based IO
    [13:47:29] [Server thread/INFO]: Default game type: SURVIVAL
    [13:47:29] [Server thread/INFO]: Generating keypair
    [13:47:30] [Server thread/INFO]: Starting Minecraft server on *:25565
    [13:47:30] [Server thread/INFO]: Using default channel type
    [13:47:31] [Server thread/INFO]: [TesterPlugin] Loading TesterPlugin v1.0.0
    [13:47:31] [Server thread/INFO]: [TesterPlugin] Enabling TesterPlugin v1.0.0
    [13:47:31] [Server thread/INFO]: Preparing level "world"
    [13:47:31] [Server thread/INFO]: Reloading ResourceManager: Default, bukkit
    [13:47:32] [Server thread/INFO]: Loaded 6 recipes
    [13:47:33] [Server thread/INFO]: -------- World Settings For [world] --------

    <snipped>

    [13:47:33] [Server thread/INFO]: -------- World Settings For [world_nether] --------

    <snipped>

    [13:47:33] [Server thread/INFO]: -------- World Settings For [world_the_end] --------

    <snipped>

    [13:47:33] [Server thread/INFO]: Arrow Despawn Rate: 1200 Trident Respawn Rate:1200
    [13:47:33] [Server thread/INFO]: Server permissions file permissions.yml is empty, ignoring it
    [13:47:33] [Server thread/INFO]: Done (2.029s)! For help, type "help"
    >
    >ver
    [13:49:03] [Server thread/INFO]: This server is running CraftBukkit version git-Spigot-b9baf71-df371c1 (MC: 1.15.2) (Implementing API version 1.15.2-R0.1-SNAPSHOT)
    [13:49:03] [Server thread/INFO]: Checking version, please wait...
    [13:49:04] [Thread-12/INFO]: You are running the latest version
    >pl
    [13:49:05] [Server thread/INFO]: Plugins (1): TesterPlugin
    Never got the error
     
  7. I also have this problem and there is no world saving after executing the // regen command in WorldEdit. I removed all plugins to check where the error was. I put a link to lastet logs server.
    https://paste.enginehub.org/773i9NZBN
     
    • Like Like x 1
  8. //regen is too much of a big command and makes your server crash. The server cannot finish the task so yeah, it doesn't save the world. Btw next time make your own topic cause this isn't even related to my issue.
     
  9. first of all it is about marking up to 150 blocks - and secondly if you read it correctly it has exactly the same problem as you - I wrote it by the way - which was to describe the problem once again when you explained what was going on
     
  10. 1. //regen is buggy, even with 150 blocks it crashes cause the server cannot handle it
    2. This has nothing to do with my problem, the server doesn't crash because of it but because of //regen
     
  11. I get the "Initializing Legacy Material Support. Unless you have legacy plugins and/or data this is a bug!" error on a plugin I am updating. The following code produces it:
    Code (Text):
    Block face = s.getBlock().getRelative(((org.bukkit.material.Sign) (s.getData())).getAttachedFace());
    Admittedly those are deprecated calls, and need to be rewritten. Just an fyi.
     
  12. I also have the issue that it sometimes doesn't load at startup, but while the server is already running which causes a lag spike.
     
  13. Run any code that could load legacy support at startup.
     
  14. Why can't this just get fixed?
     
  15. I've always had this warning on my server startup (paper 1.15.2).....never noticed any issues in game and I have an extremely complex multiverse server setup. I just ignore it.
     
  16. it's Because you run it on "offline-mode=true" "online-mode=false" so that's why it says that Warn (NOTE : It's a Warning not an Error so It's Ok)