1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Bug Internal Exception, Connection Refused - BUNGEE KICKS RANDOMLY

Discussion in 'Bugs & Feature Requests' started by Haxirr, May 6, 2013.

?

Does this happen to you?

  1. Yes

    4 vote(s)
    80.0%
  2. hell nah

    1 vote(s)
    20.0%
  1. So I have my hub server set up and everything is working fine but then I get about 30 players on my faction server and I see people start leaving left and right.


    For some reason, bungee keeps kicking my players randomly showing them this:


    [​IMG]

    I am running Spigot #844 , It was also doing this with Craftbukkit. I've heard of someone else having this error. Help me, thanks :D
     
  2. I am running 2 servers with a hub currently and want to get this issue fixed before I add the rest of the servers. 12gb of RAM across the Hub server and the Faction server.

    My config file is :

    Code (Text):
    listeners:
    - fallback_server: hub
      max_players: 200
      host: *******************
      tab_size: 60
      force_default_server: false
      texture_size: 16
      motd: Hub Server
      default_server: hub
      forced_hosts:
    servers:
      hub:
        address: ***********
        restricted: false
      faction:
        address: *******
        restricted: false
    stats: ********************
    permissions:
      default: []
      admin:
      - bungeecord.command.server
      - bungeecord.command.list
      - bungeecord.command.alert
      - bungeecord.command.end
      - bungeecord.command.ip
      - bungeecord.command.reload
    tab_list: GLOBAL_PING
    player_limit: -1
    online_mode: true
    timeout: 30000
    groups:
      *******:
      - admin
      **********:
      - admin
     
     
  3. I'm using 844 as well, but my problem is rarely anyone can connect.

    I have however found out something that might be of interest, might be related to you.
    I think there is a form of anti-DDoS added in somewhere.
    My issue is if you try to connect after the server was pinged from the server list, it sees it as some sort of DDoS (guessing) and denies the second ping/connect. If you let the list load and ping, then wait about 3-10 seconds, you can connect.

    You issue might be due to too many pings from the users to the server.
    All theory though.
     
  4. Its not DDoS, I had my DDoS protection host look into this. Its a connection problem on my end.