InvalidPluginException

Discussion in 'Spigot Plugin Development' started by DonutVreterNL, May 26, 2015.

  1. Hi,

    So i'm working on a plugin that includes LibsDisguises. But when i start the server the plugin won't load. I used the depend: LibsDisguises in my plugin.yml but it won't help. And yes i've installed Protocolib and Libsdiguises in the server. Anyone have a solution?

    Code (Text):
    26.05 18:14:08 [Multicraft] Skipped 56 lines due to rate limit (30/s)
    26.05 18:14:07 [Server] INFO at java.net.URLClassLoader.findClass(URLClassLoader.java:354) ~[?:1.7.0_65]
    26.05 18:14:07 [Server] INFO at java.security.AccessController.doPrivileged(Native Method) ~[?:1.7.0_65]
    26.05 18:14:07 [Server] INFO at java.net.URLClassLoader$1.run(URLClassLoader.java:355) ~[?:1.7.0_65]
    26.05 18:14:07 [Server] INFO at java.net.URLClassLoader$1.run(URLClassLoader.java:366) ~[?:1.7.0_65]
    26.05 18:14:07 [Server] INFO Caused by: java.lang.ClassNotFoundException: me.libraryaddict.disguise.disguisetypes.Disguise
    26.05 18:14:07 [Server] INFO ... 6 more
    26.05 18:14:07 [Server] INFO at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[server.jar:git-Spigot-8a983f9-e81edfc]
    26.05 18:14:07 [Server] INFO at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:64) ~[server.jar:git-Spigot-8a983f9-e81edfc]
    26.05 18:14:07 [Server] INFO at java.lang.Class.forName(Class.java:270) ~[?:1.7.0_65]
    26.05 18:14:07 [Server] INFO at java.lang.Class.forName0(Native Method) ~[?:1.7.0_65]
    26.05 18:14:07 [Server] INFO Caused by: java.lang.NoClassDefFoundError: me/libraryaddict/disguise/disguisetypes/Disguise
    26.05 18:14:07 [Server] INFO at java.lang.Thread.run(Thread.java:745) [?:1.7.0_65]
    26.05 18:14:07 [Server] INFO at net.minecraft.server.v1_8_R1.MinecraftServer.run(MinecraftServer.java:505) [server.jar:git-Spigot-8a983f9-e81edfc]
    26.05 18:14:07 [Server] INFO at net.minecraft.server.v1_8_R1.DedicatedServer.init(DedicatedServer.java:152) [server.jar:git-Spigot-8a983f9-e81edfc]
    26.05 18:14:07 [Server] INFO at org.bukkit.craftbukkit.v1_8_R1.CraftServer.loadPlugins(CraftServer.java:291) [server.jar:git-Spigot-8a983f9-e81edfc]
    26.05 18:14:07 [Server] INFO at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [server.jar:git-Spigot-8a983f9-e81edfc]
    26.05 18:14:07 [Server] INFO at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[server.jar:git-Spigot-8a983f9-e81edfc]
    26.05 18:14:07 [Server] INFO at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[server.jar:git-Spigot-8a983f9-e81edfc]
    26.05 18:14:07 [Server] INFO org.bukkit.plugin.InvalidPluginException: java.lang.NoClassDefFoundError: me/libraryaddict/disguise/disguisetypes/Disguise
     
  2. Can you post your plugin.yml
     
  3. Try using a more update version of LibsDisguise. Had this problem last night