Spigot InventoryLock | NoDrop/NoMove, Lightweight, Great for Hubs 2.0.6

Prevent inventory activity with the simple, lightweight InventoryLock

  1. DarkSoldier submitted a new resource:

    InventoryLock - Prevent players from re-arranging their inventory!

    Read more about this resource...
     
  2. DarkSoldier updated InventoryLock with a new update entry:

    Permissions

    Read the rest of this update entry...
     
  3. DarkSoldier updated InventoryLock | NoDrop and NoMove in One! with a new update entry:

    Config.yml and Bypass Permissions

    Read the rest of this update entry...
     
  4. Hello, how are you?
     
  5. Hi :) I'm just wanting to say Hi.
     
  6. Nice to meet you :D
     
  7. Nice to meet you to.

    Hi.
     
  8. Hello there i was wondering if i could make a video on this plugin like a review kinda thing cause i wana start reviewing premium mc plugins for my youtube channel it is https://www.youtube.com/channel/UCVToxBg49jHgZ8YNkBoLJUQ

    reply to this so we can talk or add my on skype "jonny.skiadas" It will say im from greece
     
  9. Yes you may make a video about this plugin.
     
  10. Thanks working nice! i r8 8/8 noregr8.
     
    #12 kampuman, Jul 9, 2015
    Last edited: Jul 9, 2015
  11. pls update to Bukkit 1.10
     
  12. DarkSoldier updated InventoryLock | Ideal for Hub Servers! NoDrop/NoMove with a new update entry:

    InventoryLock v2.0!

    Read the rest of this update entry...
     
  13. DarkSoldier updated InventoryLock | Ideal for Hub Servers! NoDrop/NoMove with a new update entry:

    Crucial Permission Update

    Read the rest of this update entry...
     
  14. Code (Text):
    [01:10:21 ERROR]: Could not load 'plugins\InventoryLock.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: me/darksoldier/invlock/Main has been compiled by a more recent version of the Java Runtime (class file version 53.0), this version of the Java Runtime only recognizes class file versions up to 52.0
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[paper.jar:git-Paper-1567]
            at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[paper.jar:git-Paper-1567]
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) ~[paper.jar:git-Paper-1567]
            at org.bukkit.craftbukkit.v1_12_R1.CraftServer.loadPlugins(CraftServer.java:318) ~[paper.jar:git-Paper-1567]
            at net.minecraft.server.v1_12_R1.DedicatedServer.init(DedicatedServer.java:222) ~[paper.jar:git-Paper-1567]
            at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:616) ~[paper.jar:git-Paper-1567]
            at java.lang.Thread.run(Unknown Source) [?:1.8.0_181]
    Caused by: java.lang.UnsupportedClassVersionError: me/darksoldier/invlock/Main has been compiled by a more recent version of the Java Runtime (class file version 53.0), this version of the Java Runtime only recognizes class file versions up to 52.0
            at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.8.0_181]
            at java.lang.ClassLoader.defineClass(Unknown Source) ~[?:1.8.0_181]
            at java.security.SecureClassLoader.defineClass(Unknown Source) ~[?:1.8.0_181]
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:152) ~[paper.jar:git-Paper-1567]
            at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:104) ~[paper.jar:git-Paper-1567]
            at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_181]
            at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.8.0_181]
            at java.lang.Class.forName0(Native Method) ~[?:1.8.0_181]
            at java.lang.Class.forName(Unknown Source) ~[?:1.8.0_181]
            at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:82) ~[paper.jar:git-Paper-1567]
            at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:127) ~[paper.jar:git-Paper-1567]
            ... 6 more
    Can you please compile this plugin to something that is more widely supported regarding Java?

    Using Java versions:
    • openjdk version "1.8.0_181"
    • OpenJDK Runtime Environment (build 1.8.0_181-8u181-b13-1~deb9u1-b13)
    • OpenJDK 64-Bit Server VM (build 25.181-b13, mixed mode)

    Thanks in advance!
     
  15. Can this be used to lock out a specific slot?
     
  16. No, as of now the functionality is limited to locking out an entire inventory in specified worlds. I can work on this feature for the 1.14 release if you so desire.