Is 1.15 the best version for plugins?

Discussion in 'Spigot Discussion' started by ThatGuyLogi, Mar 24, 2020.

  1. I am developing my own plugins for my server and am wondering if I should go with 1.15 or not. Got any advice?
     
  2. It is always a good practice to develop for the latest Spigot version which is currently 1.15.2 (API version 1.15). Some people explicitly support 1.8 as well, even if sometimes (not always) that's completely different code.
     
  3. It is easiest to code on the newest version, which has the most feature and the most up-to-date Spigot API.
    But if you support multiple versions right from the get-go, supporting other versions like 1.16 may be easier to implement as your code is made to work with multiple different versions in mind