Is there a plugin that disables /fly and /gm, in only one world?

Discussion in 'Spigot Plugin Help' started by Monkeyfume, Aug 15, 2015.

  1. Donators and staff who have access to the /fly and /gm commands can fly over walls and cheat at the parkour in my spawn world.
    I want to disable flying and gamemode (to make the whole world a pure-survival, no fly zone).
     
  2. Use permissions ;)

    PermissionsEx:
    worlds:
    -survivalworld
    - -essentials.fly
    - -essentials.gamemode
    (I think)
     
    • Winner Winner x 2
  3. How is PEx supposed to know what world I want the commands disabled in? I think your formatting is incorrect, if this even works.
     
  4. Yes, the Dogoe is right. You have to disable the permissions nodes - essentials.fly and - essentials.gamemode with this negating character:
    - -essentials.fly - -essentials.gamemode
    Hope we've been useful, have a nice day.
     
    • Useful Useful x 2
  5. We won't make your format for you to copy paste... Open the PermissionEx Wiki and learn. Yes, this works very well and this is what i'm using on my server.
     
    • Funny Funny x 1
  6. Code (Text):
      groupyname:
        inheritance:
        - Member
        permissions:
        - u.so.nice
        - staph.yuo.nice
        - nah.yuoo.nice
        - aww.thanks
        worlds:
          exampleworld:
            permissions:
            - your.fancy.permission
    This works 100%
     
    • Agree Agree x 2
  7. Skript!

    Code (Text):

    on command:
     if command is "gm" or "fly":
      if "%world of player%" is "whatever":
       cancel event
       message "&c&lSorry! &7That command is blocked here."
     
     
    • Funny Funny x 2
    • Agree Agree x 1
    • Winner Winner x 1
  8. Wow, lots of people online! ;) This community is very good :D
     
    • Agree Agree x 1
  9. You have no idea :)
     
  10. Uhm, I know, I'm spamming... But I'm desperate... Could you just watch my thread, please? I'm really stuck... Thanks and sorry for saying that...
     
  11. I'll try
     
    • Useful Useful x 1
  12. Wow! Thank you again Veron. This is the second time you have made a plugin for me. I appreciate that.

    But I don't appreciate the fact that it doesn't work.
     
    #13 Monkeyfume, Aug 16, 2015
    Last edited: Aug 16, 2015
    • Funny Funny x 1
  13. Just tag me next time due to spam i dont watch threads. Download the updated jar
     
    • Useful Useful x 1
  14. @Veron I'll see if it works in one minute
     
  15. [​IMG]
     
    • Useful Useful x 1
  16. @Veron, still doesn't work. Other players can still use the commands that I used your plugin to block:
    Code (Text):
    [00:07:31] [Server thread/INFO]: _Ascension issued server command: /fly
    [00:07:33] [Server thread/INFO]: _Ascension issued server command: /fly
    [00:07:34] [Server thread/INFO]: _Ascension issued server command: /fly
    [00:07:47] [Server thread/INFO]: Monkeyfume issued server command: /wcmds
    [00:07:47] [Server thread/ERROR]: null
    org.bukkit.command.CommandException: Unhandled exception executing command 'wcmds' in plugin WorldCommands v1.0
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:46) ~[spigot-1.8.jar:git-Spigot-b1e6da1-1092acb]
        at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141) ~[spigot-1.8.jar:git-Spigot-b1e6da1-1092acb]
        at org.bukkit.craftbukkit.v1_8_R1.CraftServer.dispatchCommand(CraftServer.java:645) ~[spigot-1.8.jar:git-Spigot-b1e6da1-1092acb]
        at net.minecraft.server.v1_8_R1.PlayerConnection.handleCommand(PlayerConnection.java:1115) [spigot-1.8.jar:git-Spigot-b1e6da1-1092acb]
        at net.minecraft.server.v1_8_R1.PlayerConnection.a(PlayerConnection.java:950) [spigot-1.8.jar:git-Spigot-b1e6da1-1092acb]
        at net.minecraft.server.v1_8_R1.PacketPlayInChat.a(PacketPlayInChat.java:26) [spigot-1.8.jar:git-Spigot-b1e6da1-1092acb]
        at net.minecraft.server.v1_8_R1.PacketPlayInChat.a(PacketPlayInChat.java:53) [spigot-1.8.jar:git-Spigot-b1e6da1-1092acb]
        at net.minecraft.server.v1_8_R1.PacketHandleTask.run(SourceFile:13) [spigot-1.8.jar:git-Spigot-b1e6da1-1092acb]
        at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) [?:1.8.0_31]
        at java.util.concurrent.FutureTask.run(Unknown Source) [?:1.8.0_31]
        at net.minecraft.server.v1_8_R1.MinecraftServer.z(MinecraftServer.java:683) [spigot-1.8.jar:git-Spigot-b1e6da1-1092acb]
        at net.minecraft.server.v1_8_R1.DedicatedServer.z(DedicatedServer.java:316) [spigot-1.8.jar:git-Spigot-b1e6da1-1092acb]
        at net.minecraft.server.v1_8_R1.MinecraftServer.y(MinecraftServer.java:623) [spigot-1.8.jar:git-Spigot-b1e6da1-1092acb]
        at net.minecraft.server.v1_8_R1.MinecraftServer.run(MinecraftServer.java:526) [spigot-1.8.jar:git-Spigot-b1e6da1-1092acb]
        at java.lang.Thread.run(Unknown Source) [?:1.8.0_31]
    Caused by: java.lang.ArrayIndexOutOfBoundsException: 0
        at me.veron.worldcommands.com.Commands.onCommand(Commands.java:28) ~[?:?]
        at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44) ~[spigot-1.8.jar:git-Spigot-b1e6da1-1092acb]
        ... 14 more
    [00:07:52] [Server thread/INFO]: Monkeyfume issued server command: /wcmds disable
    [00:07:58] [Server thread/INFO]: Monkeyfume issued server command: /wcmds disable /fly
    [00:08:03] [Server thread/INFO]: Monkeyfume issued server command: /wcmds disable /gamemode
    [00:08:06] [Server thread/INFO]: _Ascension issued server command: /fly
    [00:08:08] [Server thread/INFO]: _Ascension issued server command: /fly
    I am being sent messages just like in your screenshot, but it doesn't stop players from using the commands!
     
    • Useful Useful x 1
  17. @Veron thank you for everything! The plugin works perfectly now. You saved the balance of order on my server with this plugin. I am forever indebted to you.
     
  18. Wow, this is awesome... You've made a plugin for him in a while... Awesome community, such wow.
     

Share This Page