Is this plugin error or it has to do with shared host?

Discussion in 'Systems Administration' started by vanjavk, Aug 13, 2015.

?

Who's fault is this?

  1. My noobish plugins setup.

    0 vote(s)
    0.0%
  2. HordeHost hosting screwed up something.

    1 vote(s)
    100.0%
  1. Hosting: HostHorde
    Java: 7 (when I asked to get Java 8, they said they don't offer java 8 -.-)
    and they're using Multicraft
    Package: Ultimate (6gb)


    Ok so this is LOG from starting of server till the crash. (it's what I have logged in logs folder)
    http://pastebin.com/QFvMqpLU (now at last line server crashes and this is full log file)
    Please note that time on this log goes from TOP to BOTTOM.

    Now this is what I successfully recovered by copy pasting multicraft console in the time of crash:
    http://pastebin.com/qF3hxs9Y
    Please note that time on this log goes from BOTTOM to TOP.

    After sending in a ticket they said it's a plugin problem. Now I'm asking you, is it a plugin problem or it's something wrong with their host?
    NO crash-report created, I just have logs folder which I full copied for you in first link, and console error which I also copied.

    And if you say it's a plugin then what kind, how can I fix a plugin problem that causes no lag, just crash at 20-40 mins without any errors at all.

    This happened several times.

    edit: I tried forcibly crashing server with worldedit and did so with success and since i thought hey maybe all crashes on this host get that stupid java error, but no when I crashed with this I got full nice error report shown here http://pastebin.com/DRUmecAr
     
    #1 vanjavk, Aug 13, 2015
    Last edited: Aug 13, 2015
  2. And before you say anything about Ambiguous plugin name `ProtocolLib' for files `plugins/ProtocolLib186.jar' and `plugins/ProtocolLib.jar' in `plugins' and 2 versions behind spigot, I tried again with removing 1 extra protocollib.jar and updated spigot to latest version but still no luck, crashes after 30 min
     
  3. Just an FYI, When you are posting logs make sure to take out the IP.
     
  4. Do you have some quick way?
     
  5. Look for the IP's and remove them...
    There is another log file that we need /tmp/jvm-26819/hs_error.log
     
    • Agree Agree x 1
  6. I sent in a ticket for that, guy who told me it was a plugin problem said he didn't had access to that file.
     
  7. Execute "readlog /tmp/jvm-26819/hs_error.log" from the console and paste the output.
     

    Attached Files:

    • Useful Useful x 1