Is Votifier Done for?

Discussion in 'Server & Community Management' started by Flip284, Aug 14, 2013.

  1. I recently switched from one host to another and votifier suddenly does not work anymore. I have tried EVRYTHING. It appears the devs of Votifier have gone inactive, and if this is indeed a problem with votifier and not my own, as staminus says, is this the end of votifier? I've offered people money, posted on votifiers page, posted on bukkit, contacted my host, contacted enjin.....

    I am willing to pay $50 or more to anyone who can genuinely help me with this problem. I will give any information needed and try anything asked.

    Regenerated Keys (multiple times)
    Manually created keys
    Changed ports (multiple times)
    used variety of different listeners, flatfile, galistener, enjin
    Completely deleted votifier.jar/folder
    Tried using host 0.0.0.0
    Contacted the host, staminus (they claim problem is with votifier itself)

    According to logs, the plugin enables fine, no errors, but whenever someone votes I get the error: Unable to decrypt vote record. make sure that your public key matches the one you gave the server list.

    The keys match and I have proof here, as you can see a successful connection was made with Mine status, proving that the public key, host and port are fine.
    [​IMG]



    Here is a pastie of all of votifiers loggings: Startup/Shutdown/Vote
    http://pastie.org/8234784


    I posted detailed reports of some of the things I've been doing here:
    http://dev.bukkit.org/bukkit-plugins/votifier/forum/help/56325-votifier-switched-hosts-severe-error/#p4
     
    #1 Flip284, Aug 14, 2013
    Last edited: Aug 14, 2013
    • Disagree Disagree x 1
  2. LiLChris

    LiLChris Retired Moderator
    Retired

    If Votifier stopped working 99% of server listing sites would magically break at once.

    It's 2am for me, so I can give it a shot tomorrow when I wake up and see what the issue is, if someone doesn't beat me to it by then.
     
  3. I realize it's still working on most, It ran perfectly on my server for 9 months, it only stopped working for me when I switched hosts. My host (Staminus) has looked it over and they think it is a problem with votifier and that I should contact the dev. The problem is, the devs are inactive, if more people start to have problems alike I don't know what will happen to votifier.

    I appreciate any help you can give, this plugin is essential for my server. It's been down a few days now and im desperate. I'd be willing to pay you just for your help.
     
    • Disagree Disagree x 1
  4. Have you tried changing the port? I would try the default one.
     
  5. I was at first using the default 8193 port, Staminus told me this may be the issue and told me to follow the instructions of this article: http://www.hosthorde.com/clients/knowledgebase/22/Installing-Votifier.html
    Changing the port didn't fix the problem, of course.... but it's still good to use your own port.
     
    • Disagree Disagree x 1
  6. joehot200

    Supporter

    Well good, then these stupid servers will stop getting their players to vote just cos they wanna get big an' popular.
    Then the small servers might actually get a chance.
     
    • Disagree Disagree x 4
    • Agree Agree x 1
  7. Flip284 - I've never had an issue with Votifier, so I doubt its dead. In other news your signature is god awful, I wish you'd change it...

    Sorry, that's offtopic. :/
     
  8. CustomForms

    CustomForms Retired Moderator
    Retired Supporter

    Im going to assume the port you used is a backup or safety port that your computer may just like to keep. Try something around the mid 8k's or early 9k's. If that doesnt work, as your new host if your firewall/protection would block any sort of thing along the lines of votifier; its a large possibility. I've never had a problem with votifier.
     
  9. LiLChris

    LiLChris Retired Moderator
    Retired

    Flip284 can you jump on IRC would make testing things a whole lot easier than replying each time.
     
  10. I tried multiple ports, including higher number ports. If the problem were the port the test connection shown in the screen shot above wouldn't have worked too. I will try this again though.

    Sure! I won't be able to get on for about an hour though.



    This problem was FINALLY resolved, I deleted votifier like 10 times and reloaded it, it eventually gave me new keys and was finally able to work. thanks a lot for the help though.
     
    #10 Flip284, Aug 14, 2013
    Last edited: Aug 15, 2013
    • Disagree Disagree x 1
    • Informative Informative x 1