Issue With Running BungeeCord On My Mac

Discussion in 'Server & Community Management' started by ig88hk, Aug 9, 2013.

  1. im having and issue whenever i try to start up BungeeCord via Terminal i Get This...
    anyone know how to fix this?
    Code (Text):
    Exception in thread "main" java.lang.UnsupportedClassVersionError: net/md_5/bungee/BungeeCord : Unsupported major.minor version 51.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
        at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
    logout
     
  2. Dmck2b

    Services Staff

    Your java is probably out of date.
     
  3. its not that my java is fully upgraded.
     
  4. Dmck2b

    Services Staff

    Type java -version into terminal, if it doesnt say Java 7 therein lies the issue.
     
  5. CCT

    CCT
    Supporter

    Is there a way to download the latest version of Java through the command line on OS X?