1. Guest, as per the stickied thread, this forum has not been in use since 2014. All bugs and feature requests should be posted to JIRA.

Bug Item entity XXX has no item?!

Discussion in 'Bugs & Feature Requests' started by Courtney, Dec 1, 2014.

  1. I believe it's caused by hoppers that use custom value spigot transfer.
    It started happening after latest recompile, please let me know if it's something on my end.

    [08:24:27 ERROR]: Item entity 80342 has no item?!
    [08:24:27 ERROR]: Item entity 80342 has no item?!
    [08:24:28 ERROR]: Item entity 80342 has no item?!
    [08:24:28 ERROR]: Item entity 80342 has no item?!
    [08:24:28 ERROR]: Item entity 80342 has no item?!
    [08:24:28 ERROR]: Item entity 80342 has no item?!
    [08:24:28 ERROR]: Item entity 80342 has no item?!
    [08:24:28 ERROR]: Item entity 80342 has no item?!
    [08:24:28 ERROR]: Item entity 80342 has no item?!
    [08:24:28 ERROR]: Item entity 80342 has no item?!
    [08:24:28 ERROR]: Item entity 80342 has no item?!
    [08:24:28 ERROR]: Item entity 80342 has no item?!
    [08:24:28 ERROR]: Item entity 80342 has no item?!
    [08:24:28 ERROR]: Item entity 80342 has no item?!
    [08:24:28 ERROR]: Item entity 80342 has no item?!
    [08:24:28 ERROR]: Item entity 80342 has no item?!
    [08:24:28 ERROR]: Item entity 80342 has no item?!
    [08:24:28 ERROR]: Item entity 80342 has no item?!
    [08:24:28 ERROR]: Item entity 80342 has no item?!
    [08:24:28 ERROR]: Item entity 80342 has no item?!
     
  2. same problem here...

    [15:13:10] [Client thread/ERROR]: Item entity 8810 has no item?!
    [15:13:10] [Client thread/ERROR]: Item entity 8810 has no item?!
    [15:13:10] [Client thread/ERROR]: Item entity 8810 has no item?!
    [15:13:10] [Client thread/ERROR]: Item entity 8810 has no item?!
    [15:13:10] [Client thread/ERROR]: Item entity 8810 has no item?!
    [15:13:18] [Client thread/ERROR]: Item entity 8811 has no item?!
    [15:13:18] [Client thread/ERROR]: Item entity 8811 has no item?!
    [15:13:18] [Client thread/ERROR]: Item entity 8811 has no item?!
    [15:13:36] [Client thread/ERROR]: Item entity 8824 has no item?!
    [15:13:36] [Client thread/ERROR]: Item entity 8824 has no item?!
    [15:13:36] [Client thread/ERROR]: Item entity 8824 has no item?!
    [15:13:36] [Client thread/ERROR]: Item entity 8824 has no item?!
    [15:13:36] [Client thread/ERROR]: Item entity 8824 has no item?!
     
  3. Dmck2b

    Services Staff

    I've seen this in the past in 1.7.*, it's a normal side effect of items combining afaik.
     
  4. I've been on 1.7.10 for quite some time (latest builds after drama) never had that issue. =\
    It started happening shortly after I switched to 1.8 there was no change in config.
     
  5. Archangel

    Supporter

    Agreed, there's the issue of the spam. So far, due to these errors, I have yet to see a change in the content of the server.
     
  6. Puremin0rez

    Moderator

    It's kind of silly that it spams the console rather than destroying the entity. Hopefully that could be changed.
     
    • Winner Winner x 1
  7. NullBlox

    Patron

    I was told to use /remove all -1
    I did that reset all my item frames and the less than 24 hrs later same thing happens.
    This is on the 1.8 BuildTools #25 Jan 20

    I do not think this is happend because one of us added new plugins.
    We also did not change anything aside from switching to 1.8.
    I do get that the switch makes some kinda change but this spam is not cool by any means.

    An the so called fix with that command seams to be temp if best.
    So please look into this its a thing on current 1.8 Build Tools.

    Link to more on the Topic. http://www.spigotmc.org/threads/insane-console-spam.1251/page-2

    [​IMG]

    [​IMG]
     
  8. PhanaticD

    Patron

    saying "buildtools 25" means nothing as spigot versions can change every time you compile spigot with it.

    also I had this issue on a adventure map with mob spawner that spawned in items, didnt really affect anything
     
  9. NullBlox

    Patron

    Ok so just let it happen?
    An I talking about the #25 here https://hub.spigotmc.org/jenkins/job/BuildTools/
    So your telling me that that changes? I kinda lost on what you mean or maybe you thought I meant something different.
     
  10. Just updated my server to 1.8, and same problem. /remove all -1 solves nothing. Spigot version git-Spigot-952179b-bbf72f3 (MC: 1.8) (Implementing API version 1.8-R0.1-SNAPSHOT). :(
     
    • Useful Useful x 1
  11. NullBlox

    Patron

    Do you use Crackshot? jw.
     
  12. No. :(
     
    • Creative Creative x 1
  13. NullBlox

    Patron

    Did you try the /remove all -0 command?
    It will remove all the items and frames. You will have to reset the frames etc but It might work.
     
  14. Yep, no change either :(
     
  15. Has anyone managed to resolve this? I am still getting this and it comes up every single second.
     
  16. I managed to fix this by removing StandaloneShelves.
     
  17. That's what's causing the issue with my server aswell, Is there a fix? I'd like to keep the plugin as i kindof need it??

    Also im using Showcase standalone
     
  18. Okay, so this may not help the multitude of server owners that are having this issue but maybe they can use this to track down their problem and get it fixed..

    1) This problem can be caused by a plugin trying to spawn a non-spawnable item stack. IE a plugin tries to spawn Material.wall_sign or Material.melon_stem (there are a BUNCH more) these are items that players aren't "allowed" to hold thus they become invalid and typically get rendered as smooth stone when they are actually dropped in the world.
    2) Every time one of these non-spawnable items gets "dropped" in the world it will cause this error at least once. Often times it will constantly spam until the offending item is picked up and /clear is run on the player holding the item.
    3) If you have a plugin that spawns random items from minecraft into your world that is causing this problem contact the plugin's author and have them add this little bit of code to their plugin to fix the issue.

    You must have essentials installed and the plugin will need to hook essentials. (the plugin guys know how to do this)
    ItemStack is = new ItemStack(Material_To_Spawn);

    MetaItemStack metaStack = new MetaItemStack(is);
    if(!metaStack.canSpawn(theirplugin.getES())) {
    //System.out.println("Unspawnable item: " + is.getType().name());
    //do whatever they need to do, eg: return/continue/break etc.
    }
     
    • Informative Informative x 1
    • Useful Useful x 1
  19. all right this is crashing my server so i want this to stop like now
    instead of copy pasting im just going to upload this one particular log i have which is insane everybody here shows like one or 2 strings of items it cant spawn or something but with mine its just ALL OVER THE PLACE
    ill take out all of the names of the players
    server ip i could care less id rather have more people know about it anyway
    its just a creative server ages 16+

    Edit: I also dont know how to get my craftbukkit server to start up a console when i run it,
    yes i have an rcon that i can input commands into but its remotely the same to the console that vanilla servers bring up when you run them
     

    Attached Files:

    #19 SSEEBBYZ, Apr 11, 2016
    Last edited: Apr 11, 2016