Solved Item "Q" Drop Glitch

Discussion in 'Spigot Plugin Help' started by FuzzyWartface, Jun 18, 2018.

  1. Hello! I run a server with the latest Spigot build. Just recently, a test player of mine noticed that when you hold more than one item in your hand, and push Q to drop it, it throws the whole amount in your hand. This wouldn't be too bad.....except when you throw the items, it all morphs into one, and it appears that you only dropped 1 entity. You then pick up what you dropped, and you only get ONE. Me and my friend suspected it was ClearLag, and knowing of .yml common errors, we completely deleted the config folder. However, the error still persists, and my friend now thinks its has to be Spigot.yml. This is why I am posting this here. All the files i have on my server are copied directly from my old server to this one, so there were minimal changes in anything. My old server never had this problem. My server is to be opened to over 132 players in less than 7 days... any help you can provide me with would be appreciated greatly! :D

    [​IMG]
     

    Attached Files:

  2. Give us a list of plugins that you are using the problem could be in one of them.
     
  3. I added an attached file with my plugins
     
  4. What does "SoulJars" do?
    Are you using this plugin?
     
    • Like Like x 1
  5. Nope, SoulJars is an addition to SlimeFun. It allows players to create spawners from killing mobs, while holding a "jar" in their inventory.
     
  6. So, I went back through console and looked around and saw some errors coming out from LobbyCompass. I deleted the .jar file for LobbyCompass, restarted the server, and it works great! I may not need LobbyCompass anyways, but I'll try to find a solution for anyone with the same problem.
     
    • Like Like x 1
  7. Hi , i got this problem too but i dont have LobbyCompass , so i dont understand why it do that (i know this thread is 1 year old but i exactly have the same glitch , so i replyed here
    )