Solved JAR creation failed. See details for additional information.

Discussion in 'Spigot Plugin Development' started by ScienceCodeDE, Jul 22, 2018.

Thread Status:
Not open for further replies.
  1. Hey Guys.

    Today I have an new Problem. I closed my SkyPvP Project, because I can't export it.

    The Story:

    I have to clear my workspace, because an error. So I have copied my files and I put it into an WinRAR Archive.
    Now I cleared the workspace and start Eclipse again. Now I closed and put my files again into the workspace. So now I would export my Plugin, but ERROR:
    [​IMG]
    So I clicked on "Details >>" and:
    [​IMG]
    Now I dont know more. I tryed all. I refreshed the project, remove build paths and put it again in, ...!

    I hope somebody can help me.

    Sry for my bad english. I know my english is pretty bad.

    :mad::mad::mad::mad:

    ----------------------------------------------------------------------------
     
  2. Did your plugin work before? Could you show use the actual code?
     
  3. You cannot create a jar when there are errors that you have to fix.
     
  4. This always happens to me in eclipse, what I am doing wrong was I forgot to add my libraries back lol. Sometime the ide was just parsing too much data that updating every error was slow.
     
  5. Yey, of course.
     
  6. Yeah I know it, but how to fix compile Errors?!
     
  7. You should switch to a more reliable and organized build service. Using Eclipse, even changing the order of the build path can break compilation. Try Maven or Gradle.
     
  8. I tryed already Maven, but I dont like this, because it has some problems.
     
  9. Have you checked that the code does not contain any errors? Also I would recommend you to switch to a in my opinion better IDE from Jetbrains and you should get Maven to work.

    By the way: why de.gomme?
     
  10. 1.) Nope it has no errors and it is not the one plugin that dont work. I have more than 20 Projects that dont work now.

    2.) I dont want to switch. I code also other things with Java and so I dont won't to change all. :3

    3.) Because there is a YouTuber named GommeHD and in the time when I liked him I startet with coding, but now not more. I didn't change it. :D
     
  11. Either you do not have all libraries set up correctly or you have errors in your code. From using Eclipse those are the only two possibilities for that error type (that I know of). If you are 100% sure the code it work, then you need to make sure you have added all the proper libraries to each of the projects.
     
  12. On eclipse don't you have to manually import things? You might wanna check how you're importing everything.
     
  13. I know that, that when a ! is on the Project. But there is only a warning sign. The warning sign is caused by an deprecation Thing. I think I recode the shit.
     
  14. Maven will work.

    It might take some work, but it's absolutely worth it.

    Yeah, I know that it was just weird, I don't code with de.rewinside either. :p

    Recodes are always good, there is always space to clean up the code and make stuff better.
    https://google.github.io/styleguide/javaguide.html
     
  15. Your IDE has returned some class. In theses class, you seems have warning(s) and it can be an error for the compiler. Try to resolve them and compile again :)
     
  16. I recoded it just. But thank for helping. Now it works!
     
Thread Status:
Not open for further replies.