Jar not loading

Discussion in 'Spigot Help' started by Daxxiee, May 16, 2016.

  1. Hey, so I get this every time I run our upcoming server

    Code (Text):
    16.05 01:46:32 [Multicraft] Loading server properties
    16.05 01:46:32 [Multicraft] Starting server!
    16.05 01:46:32 [Multicraft] Loaded config for "Mod: Spigot"
    16.05 01:46:32 [Multicraft] Server executable "/usr/bin/java" not found, server startup might fail!
    16.05 01:46:32 [Multicraft] Failed to obtain process information: NoSuchProcess no process found with pid 9595
    16.05 01:46:32 [Server] INFO Failed to run command '/usr/bin/java': No such file or directory
    16.05 01:46:32 [Multicraft] Server shut down (starting)
    16.05 01:46:32 [Multicraft] Restarting crashed server in 5 seconds
    16.05 01:46:32 [Multicraft] Looks like a crash, check the server console. Return value: 255
    16.05 01:46:32 [Multicraft] Server stopped
    Any help?

    Using CentOS
    OVH Dedicated Server
    Multicraft Purchased & Installed

    Running Mod: Spigot, or spigot.jar
    Used spigot-1.8.8.jar

    Same error, whether running
    • Default
    • CraftBukkit
    • Spigot 1.9
    • Spigot 1.8

    Any help? Thank you!
     
  2. Have you installed java?
     
  3. CentOS automatically installs Java, to my understanding.
     
  4. ... java file not found... so either move your java files, or re-install java.
     
    • Agree Agree x 1
  5. Not necessarily, and in your case apparently not. Also, if it did it would be OpenJDK. Google how to install Oracle Java for your version of CentoOS.
     
  6. Can you provide me a quick tutorial on what to do?
     
  7. What is your verison of CentOS?
     
  8. 6.7.
     
  9. Use ubuntu, it uses less RAM from what I've heard.
     
  10. RAM is not an issue, 128GB treats us well :)
     
  11. Wait, I meant Debian. Using general less RAM is always better.
     
  12. RAM is not the issue for us, though. We'll strongly consider Debian or Ubuntu in the future, thanks for the reccomendation. But for now, we just need to figure out this issue.
     
  13. Alright. Connect through FileZilla, or WinSCP, and change the java files location to /usr/bin/java
     
  14. Can you link me the Java download from Oracle?
     
    • Agree Agree x 1
  15. Issue command:

    32Bit:
    wget --no-cookies --no-check-certificate --header "Cookie: gpw_e24=http%3A%2F%2Fwww.oracle.com%2F; oraclelicense=accept-securebackup-cookie" "http://download.oracle.com/otn-pub/java/jdk/8u91-b14/jre-8u91-linux-i586.rpm"

    64Bit:
    wget --no-cookies --no-check-certificate --header "Cookie: gpw_e24=http%3A%2F%2Fwww.oracle.com%2F; oraclelicense=accept-securebackup-cookie" "http://download.oracle.com/otn-pub/java/jdk/8u91-b14/jre-8u91-linux-x64.rpm"

    Then issue command:
    as root:
    yum localinstall thefileyoudownloaded.rpm

    not root?: Prepend sudo


    Sorry I got super busy. Hope this helps.

    EDIT: Uhh sorry just realized the links I posted was for an older version of Java, updated.
     
    #18 NinjaStix, May 16, 2016
    Last edited: May 16, 2016