Java applications crash

Discussion in 'Systems Administration' started by Fridtjof_DE, Feb 18, 2020.

  1. Hi,
    I was running many servers for months and I had no problems. But now the servers chrash for different reasons even if nobody is online. And not only Spigot servers crash, also Sponge, Forge and even the Buildtools for Spigot. The crash reports look all relativly similiar. I attached one log.
     

    Attached Files:

  2. Have you just recently updated everything to the latest 1.15 or a 1.15 version compared to months before? This would be a pretty major change as 1.15 just recently came out. If so, I'd recommend updating to the latest build since the last update and seeing if the crash has been resolved.
     
  3. Latest Java 8, latest Spigot 1.15.2, latest Bungeecord, latest Buildtools, latest Forge 1.12.2
    It seems like it is a Java problem but I didnt change anything and its a fresh Debian 9 instalation.
     
  4. MiniDigger

    Supporter

    Try updating your java to 11 or 13
     
    • Friendly Friendly x 1
  5. I don't recommend using Java higher than 8 as minecraft is made with Java 8, maybe Java 11-13 are "better" but I never used/tested them. Unless Mojang decides to force us to use Java 9 or higher, I will update X)
     
  6. Java 13 is not LTS and will be dropped within 2 months
    Java 11 is supported and should be the best option
    Also Java 8 (latest) is good tho.

    Your problem may come from one of your plugin, can you send all the plugins you are using ?
     
    • Like Like x 1
  7. MiniDigger

    Supporter

    good that nobody cares for your tests.
    countless ppl, inside and outside the minecraft community did countless tests to proof that every single java release since 9 comes with improved startup performance, reduced memory footprint and more performant garbage collection
    so update to java 14 in 2 months then?
    while I already use java 14, I dont recommend preview builds. but nothings wrong with recommending java 13 as its the latest release.
    LTS is only interesting if you are a crazy big company and upgrades are scary because you have to walk thru a swamp of legacy bullshit
    (and hey, even my company, crazy big insurance, so even more legacy bs, managed to deploy some stuff using 13 into prod already)

    this is most likely a JVM bug (no plugin should be able to produce a jvm segmentation fault, neither intentionally nor by accident) thats why I suggested to try a jvm version that isnt ancient.
     
    • Agree Agree x 1
    • Winner Winner x 1
  8. I'm in school now but when I'm home I will try newer Java version. I'm using the apt default-jdk but how can I install a newer Java on Debian 9? Do I have to do it manually?
     
  9. Expected positive answer, "nobody cares for my tests" is quite rude in my opinion. If you say so that Java 9+ is better, I might give it a try. Don't think JDK9 or higher are downloadable without user login. Could get JRE9+ instead but incase I want to build Spigot there etc

    If thats true then installing JRE/JDK 9+ on my main computer and on my servers. Been using Java 8 and I guess its time to update to either 11-13/14 if they're stable enough to run Spigot
     
  10. MiniDigger

    Supporter

    well, your OS is outdated, of course you will get outdated java too :p
    on debian stable, openjdk-11 is default-jdk.
    dont download stuff for oracles website unless you pay oracle.
    get gpl-licenced openjdk builds, the easiest way is adoptopenjdk https://adoptopenjdk.net/?variant=openjdk13&jvmVariant=hotspot
     
    • Friendly Friendly x 1
  11. I'm on Windows Server 2019 and this is outdated? >.> (well I never said I was on Windows xD)

    I never paid Oracle, their downloads was free to use on their website until they put it behind a login wall and I still prefer using Oracle's Java rather than OpenJDK as I never tried so I cannot comment on that. Unless OpenJDK is way superior and stable than Oracle, I will consider my move to the Adoptopenjdk. I checked, they do support Windows so I will give it a try :)

    Thanks for your answer and opinions :)

    ps, my english sucks so pardon if there's any grammar issues x)

    Edit2: Sorry for my posts being offtopic. I tried OpenJDK 11 and none of my apps would work (FTB launcher, MagicLauncher etc, installed OpenJDK 8 and all works fine)
     
    #11 TNTUP, Feb 19, 2020
    Last edited: Feb 19, 2020
  12. MiniDigger

    Supporter

    careful.
    free to use for educational and development purposes. NOT free for production!
    see their giant warnings here https://www.oracle.com/java/technologies/javase-jdk8-downloads.html and here https://www.java.com/en/download/
    this applies to java 8 too.
    they log the usage of their distribution of the jdk, so you really dont want to use their stuff unless you want lawyers showing up at your place.
    the code is identical. the licence is the difference.
     
    • Friendly Friendly x 1
  13. Moving on, I caused the offtopic xD Using OpenJDK8 now, no issues
     
  14. Okay, I installed Debian 10 and Java 11. Same problem :(
     
  15. I suggest that you do not run before you can walk (as the saying goes).

    First check your installation setup, log into your Debian console and use these as a starting point.

    How To Install Java on Debian 10 (see step 4 for confirmation command)
    List All Environment Variables (confirm that they are as they should be)
    And any other pre-requesites

    If that does not help, take a look at any crash logs.
     
    #15 Goldentoenail, Feb 22, 2020
    Last edited: Feb 22, 2020
  16. So I testet Debian 8, 9, 10 and Ubuntu 18 and no matter which version of Java same problem.